Talk:Hugin Compiling Ubuntu

From PanoTools.org Wiki
Revision as of 00:01, 2 January 2010 by DonPaolo (Talk | contribs)

Jump to: navigation, search

In paragraph:

In ubuntu 7.10 AMD64, replace lib64z1 and lib64z1-dev with zlib1g and zlib1g-dev in the above command. COULD SOMEBODY PLEASE DOUBLE-CHECK? You probably meant "In 32bit ubuntu 7.10 systems, ..." And yes, I this works. Heikki 12:10, 4 February 2008 (CET)


This page being about the bleeding edge versioning system installation, it would be useful to note that enfuse adds one more dependency to hugin: exiftools. You need to run sudo apt-get install libimage-exiftool-perl before running it. Personally, I think exiftools is not a good choice for this. Use something that is smaller and more focused to just copying the EXIF data over. Why not use jhead that is already part of hugin distribution? Heikki 12:18, 4 February 2008 (CET)

Folder naming convention to build

I noticed libpano now uses cmake. cd build.libpano was missing. Fixed it. Wouldn't it better to use the same naming convention for hugin, like suggesting to create a build.hugin instead of hugin-build? esby 22:31, 3 October 2009 (UTC)

Error executing hugin

I'm using ubuntu 9.10, and after compiling and installing hugin, when I try executing it I get:

$ hugin
hugin: error while loading shared libraries: libhuginbase.so.0.0: cannot open shared object file: No such file or directory
$ which hugin
/usr/local/bin/hugin

The deb package installs everything in /usr/local, and libhuginbase.so.0.0 is in /usr/local/lib/.

What am I wrong in? donPaolo 22:01, 1 January 2010 (UTC)

Personal tools
Namespaces

Variants
Actions
Navigation
tools
Tools