Difference between revisions of "PTEditor"

From PanoTools.org Wiki
Jump to: navigation, search
m (Inserting a tripod cap into a panorama)
(OSX additions)
 
(7 intermediate revisions by 4 users not shown)
Line 1: Line 1:
PTEditor is a Java based tool that displays a spherical panorama much the same way like [[PTViewer]]. To use PTEditor you must have Java installed. If you want to start PTEditor by double click make sure JAR files are linked to the Java Virtual Machine.
+
PTEditor is a [[Java]] based tool that displays a spherical panorama much the same way as [[PTViewer]]. It runs on any OS that has [[Java]] and a panotools library (pano12 or libpano12, depending on OS) installed - this currently precludes native OSX support. If you want to start PTEditor by double click make sure [[JAR]] files are linked to the [[Java]] Virtual Machine.
  
Once you started PTEditor you get an empty window with a menu. Choose 'File -> Open Panorama' from the menu to load a panorama. PTEditor loads [[equirectangular]] panorama files in Jpeg, PNG, TIFF or BMP format.  
+
Amongst other functions PTEditor provides a very convenient way to extract partial [[Rectilinear Projection|rectilinear]] views from [[spherical]] panoramas and insert them again after having edited them. PTEditor loads [[equirectangular]] panorama files in [[JPEG]], [[PNG]], [[TIFF]] or [[BMP]] format.  
  
Once you loaded a file you can pan and tilt to any position you want using the mouse or zoom in and out using + or - key. If you select 'Edit -> Extract partial view' from the Menu the current view will be saved to a file in TIFF format. You can edit this file with any image processor but you shouldn't change pixel size and you should save it with the same name.  
+
There is a nice Tutorial on [[How to use PTEditor]] and another one on [[How to allocate enough RAM for PTEditor]] on Windows.
  
If you select 'Edit -> Insert Saved View' the previously saved and edited view is inserted again into the panorama. With menu 'File -> Save Panorama' you can save your work.
+
[[Category:Software:Platform:Windows]]
 
+
[[Category:Software:Platform:Mac OS X]]
By using this method it is very easy to insert a tripod cap into a panorama. Just look straight down, extract the view, draw your tripod cap on the extracted view with any image processor, insert your amended view back into your panorama and then save the panorama.
+
[[Category:Software:Platform:Linux]]
 
+
If you want to edit large panoramas on windows the Java runtime possibly will run out of memory. In this case you must increase the memory the amount of memory assigned to Java using the command line option -Xmx<size>
+
 
+
This is best done in the open action for JAR file type: Go to explorer menu 'Tools -> Folder options' open 'File types' tab, search for JAR file type and select it. Click 'Advanced', select action 'open', click 'Edit'. In the 'Application used to perform actio' input line place the above parameter after the call to javaw.exe. F.e. <nowiki>...javaw.exe -Xmx250m -jar...</nowiki> will assign 250 Megabytes of RAM to the Java runtime.
+

Latest revision as of 08:22, 10 March 2008

PTEditor is a Java based tool that displays a spherical panorama much the same way as PTViewer. It runs on any OS that has Java and a panotools library (pano12 or libpano12, depending on OS) installed - this currently precludes native OSX support. If you want to start PTEditor by double click make sure JAR files are linked to the Java Virtual Machine.

Amongst other functions PTEditor provides a very convenient way to extract partial rectilinear views from spherical panoramas and insert them again after having edited them. PTEditor loads equirectangular panorama files in JPEG, PNG, TIFF or BMP format.

There is a nice Tutorial on How to use PTEditor and another one on How to allocate enough RAM for PTEditor on Windows.