Difference between revisions of "Hugin SDK (MSVC 2010)"

From PanoTools.org Wiki
Jump to: navigation, search
(Updated libaries list (needs to be checked by somebody else))
(Building from Source: Updated sources)
(8 intermediate revisions by 3 users not shown)
Line 75: Line 75:
 
(http://www.boost.org/)<br/>[http://sourceforge.net/projects/boost/files/boost/1.43.0/boost_1_43_0.7z/download
 
(http://www.boost.org/)<br/>[http://sourceforge.net/projects/boost/files/boost/1.43.0/boost_1_43_0.7z/download
 
<tt>boost_1_43_0.7z</tt>]
 
<tt>boost_1_43_0.7z</tt>]
(2010-05-06)<br/>(skip) [http://sourceforge.net/projects/boost/files/boost-jam/3.1.18/boost-jam-3.1.18-1-ntx86.zip/download
 
<tt>boost-jam-3.1.18-1-ntx86.zip</tt>] (2010-03-22)
 
 
|- valign="top"
 
|- valign="top"
 
| style="padding:5px; text-align:left" | <tt>Deploy</tt><br/><tt>OpenEXR</tt>
 
| style="padding:5px; text-align:left" | <tt>Deploy</tt><br/><tt>OpenEXR</tt>
 
| style="padding:5px; text-align:left" | OpenEXR library 1.6.1 and IlmBase libraries 1.0.1 (http://www.openexr.com/)<br/>[http://download.savannah.nongnu.org/releases/openexr/ilmbase-1.0.1.tar.gz <tt>ilmbase-1.0.1.tar.gz</tt>] (2007-10-22)<br/>[http://download.savannah.nongnu.org/releases/openexr/openexr-1.6.1.tar.gz <tt>openexr-1.6.1.tar.gz</tt>] (2007-10-22)
 
| style="padding:5px; text-align:left" | OpenEXR library 1.6.1 and IlmBase libraries 1.0.1 (http://www.openexr.com/)<br/>[http://download.savannah.nongnu.org/releases/openexr/ilmbase-1.0.1.tar.gz <tt>ilmbase-1.0.1.tar.gz</tt>] (2007-10-22)<br/>[http://download.savannah.nongnu.org/releases/openexr/openexr-1.6.1.tar.gz <tt>openexr-1.6.1.tar.gz</tt>] (2007-10-22)
 
|- valign="top"
 
|- valign="top"
| style="padding:5px; text-align:left" | <tt>enblend-enfuse-4.0</tt>  
+
| style="padding:5px; text-align:left" | <tt>enblend-enfuse-4.1.1</tt>  
| style="padding:5px; text-align:left" | Enblend 4.0 and Enfuse 4.0 (http://enblend.sourceforge.net/)<br/>
+
| style="padding:5px; text-align:left" | Enblend 4.1.1 and Enfuse 4.1.1 (http://enblend.sourceforge.net/)<br/>
 
{| class="wikitable"
 
{| class="wikitable"
 
|- valign="top"
 
|- valign="top"
Line 88: Line 86:
 
! style="padding:5px; text-align:left" | 64-Bit
 
! style="padding:5px; text-align:left" | 64-Bit
 
|- valign="top"
 
|- valign="top"
| style="padding:5px; text-align:left" | [http://downloads.sourceforge.net/enblend/enblend-enfuse-4.0.zip <tt>enblend-enfuse-4.0.zip</tt>] (2010-05-??)
+
| style="padding:5px; text-align:left" | [http://sourceforge.net/projects/enblend/files/enblend-enfuse/enblend-enfuse-4.1/enblend-enfuse-4.1.1-win32.zip/download <tt>enblend-enfuse-4.1.1-win32.zip</tt>] (2013-02-15)
| style="padding:5px; text-align:left" | [http://downloads.sourceforge.net/enblend/enblend-enfuse-4.0.tar.gz <tt>enblend-enfuse-4.0.tar.gz</tt>] (2010-05-??)
+
| style="padding:5px; text-align:left" | [http://sourceforge.net/projects/enblend/files/enblend-enfuse/enblend-enfuse-4.1/enblend-enfuse-4.1.1-win64.zip/download <tt>enblend-enfuse-4.1.1-win64.zip</tt>] (2013-02-15)
 
|}
 
|}
 
|- valign="top"
 
|- valign="top"
 
| style="padding:5px; text-align:left" | <tt>exiftool</tt>
 
| style="padding:5px; text-align:left" | <tt>exiftool</tt>
| style="padding:5px; text-align:left" | ExifTool 8.23 (http://www.sno.phy.queensu.ca/~phil/exiftool)<br/>[http://www.sno.phy.queensu.ca/~phil/exiftool/exiftool-8.23.zip <tt>exiftool-8.23.zip</tt>] (2010-06-20)
+
| style="padding:5px; text-align:left" | ExifTool 9.37 (http://www.sno.phy.queensu.ca/~phil/exiftool)<br/>[http://www.sno.phy.queensu.ca/~phil/exiftool/exiftool-9.37.zip <tt>exiftool-9.37.zip</tt>] (2013-09-14)
 
|- valign="top"
 
|- valign="top"
 
| style="padding:5px; text-align:left" | <tt>exiv2-0.20.0</tt>
 
| style="padding:5px; text-align:left" | <tt>exiv2-0.20.0</tt>
Line 116: Line 114:
 
|- valign="top"
 
|- valign="top"
 
| style="padding:5px; text-align:left" | <tt>libpano\pano13</tt>
 
| style="padding:5px; text-align:left" | <tt>libpano\pano13</tt>
| style="padding:5px; text-align:left" | Panorama Tools and pano13 library (http://panotools.sourceforge.net/)<br/>Mercurial repository<br/><tt>http://panotools.hg.sourceforge.net:8000/hgroot/panotools/libpano</tt>
+
| style="padding:5px; text-align:left" | Panorama Tools and pano13 library (http://panotools.sourceforge.net/)<br/>[http://sourceforge.net/projects/panotools/files/libpano13/libpano13-2.9.18/libpano13-2.9.18.tar.gz/download <tt>libpano13-2.9.18.tar.gz</tt>] 2011-05-02
 
|- valign="top"
 
|- valign="top"
 
| style="padding:5px; text-align:left" | <tt>(autopano-sift-c only) libxml2-2.7.3</tt>
 
| style="padding:5px; text-align:left" | <tt>(autopano-sift-c only) libxml2-2.7.3</tt>
Line 141: Line 139:
 
|- valign="top"
 
|- valign="top"
 
| style="padding:5px; text-align:left" | <tt>Lensfun</tt>
 
| style="padding:5px; text-align:left" | <tt>Lensfun</tt>
| style="padding:5px; text-align:left" | lensfun library for reading/writing to lens database (http://lensfun.berlios.de/)<br/> You will need unreleased version 0.2.5.1 from subversion repository svn://svn.berlios.de/lensfun for full feature set
+
| style="padding:5px; text-align:left" | lensfun library for reading/writing to lens database (http://lensfun.berlios.de/)<br/> [http://prdownload.berlios.de/lensfun/lensfun-0.2.7.tar.bz2 <tt>lensfun-0.2.7.tar.bz2</tt>] (2013-02-10)
 
+
 
|- valign="top"
 
|- valign="top"
 
! colspan="2" | Additional files only necessary for building a 64-bit SDK
 
! colspan="2" | Additional files only necessary for building a 64-bit SDK
Line 802: Line 799:
  
 
<ol>
 
<ol>
<li>Set two windows environment variables:
+
<li>Set one windows environment variables:
 
<ul>
 
<ul>
 
<li>Set variable <tt>WXWIDGETS_HOME</tt> to wxWidgets base folder <tt><SDKHOME>\wxWidgets-2.8.11</tt></li>
 
<li>Set variable <tt>WXWIDGETS_HOME</tt> to wxWidgets base folder <tt><SDKHOME>\wxWidgets-2.8.11</tt></li>
Line 826: Line 823:
 
<li>Select "Debug CMD" in Solution Configuration pull-down menu</li>
 
<li>Select "Debug CMD" in Solution Configuration pull-down menu</li>
 
<li>Select project pano13 in Solution Explorer, and then choose Build > Project Only > Build Only pano13</li>
 
<li>Select project pano13 in Solution Explorer, and then choose Build > Project Only > Build Only pano13</li>
 +
<li>Add to pano13: sys_compat_win.c
 
<li>Select "Release CMD" in Solution Configuration pull-down menu, and then choose Build > Build Solution (Note: multi-core machines, right click and build each project individually, skipping PTAInterpolate. Avoids log-file write conflict.</li>
 
<li>Select "Release CMD" in Solution Configuration pull-down menu, and then choose Build > Build Solution (Note: multi-core machines, right click and build each project individually, skipping PTAInterpolate. Avoids log-file write conflict.</li>
 
<li>Close Visual C++ 2010 Express </li>
 
<li>Close Visual C++ 2010 Express </li>
Line 1,032: Line 1,030:
 
<tt><SDKHOME>\tclap-1.2.0\include\tclap</tt>
 
<tt><SDKHOME>\tclap-1.2.0\include\tclap</tt>
  
=== Glib libary ===
+
=== Glib library ===
  
 
Needed by the lensfun library
 
Needed by the lensfun library
Line 1,039: Line 1,037:
 
<li> Decompress the file <tt>glib-2.28.8.tar.bz2</tt> to directory <tt><SDKHOME>\glib-2.28.8</tt></li>
 
<li> Decompress the file <tt>glib-2.28.8.tar.bz2</tt> to directory <tt><SDKHOME>\glib-2.28.8</tt></li>
 
<li> Open project file in <tt>glib\2.28.8\build\win32\vs10\</tt> </li>
 
<li> Open project file in <tt>glib\2.28.8\build\win32\vs10\</tt> </li>
 +
<li> Select "Release" in the Solution Configuration pull-down menu. </li>
 +
<li> '''64-bit only:''' Select "x64" in the Platform pull-down menu. </li>
 
<li> Do the following modifications:  
 
<li> Do the following modifications:  
 
<ul>
 
<ul>
<li> Change type to "static libary (.lib)" for gio, glib, gmodule, gobject and gthread</li>
+
<li> Remove the projects glib-compile-schemas, glib-genmarshal, gsettings, gspawn-win32-helper, gspawn-win32-helper-console and testglib. They are not needed. </li>
<li> Change run-time library to "Multi-threaded /MT" for all sub-projects</li>
+
<li> Change type to "static libary (.lib)" for all projects.</li>
<li> Project gio: Replace preprocessor_USRDLL directive with GIO_STATIC_COMPILATION</li>
+
<li> Change run-time library to "Multi-threaded /MT" for all projects.</li>
<li> Project glib, gmodule, gthread: Replace preprocessor_USRDLL directive with GLIB_STATIC_COMPILATION</li>
+
<li> Project gio: Replace preprocessor _USRDLL directive with GIO_STATIC_COMPILATION</li>
<li> Project gobject: Replace preprocessor_USRDLL directive with GOBJECT_STATIC_COMPILATION</li>
+
<li> Project glib, gmodule, gthread: Replace preprocessor _USRDLL directive with GLIB_STATIC_COMPILATION</li>
<li> Start building. It will create some config file and will then fail with error messages regarind intl.h </li>
+
<li> Project gobject: Replace preprocessor _USRDLL directive with GOBJECT_STATIC_COMPILATION</li>
 +
<li> Start building. It will create some config file and will then fail with error messages regarding intl.h </li>
 
<li> Open <tt><SDKHOME>\glib-2.28.8\config.h</tt>, comment out line 29: <tt> // #define ENABLE_NLS 1 </tt> </li>
 
<li> Open <tt><SDKHOME>\glib-2.28.8\config.h</tt>, comment out line 29: <tt> // #define ENABLE_NLS 1 </tt> </li>
<li> Project gio: Add path to zlib includes in wxWidgets to search path: wxWidgets-x.x.x\src\zlib </li>
+
<li> Project gio: Add path to zlib includes in wxWidgets to search path: <SDKHOME>\wxWidgets-x.x.x\src\zlib </li>
<li> Remove intl.lib from the libraries list.</li>
+
<li> '''64-bit only:''' Change target machine to "MachineX64 (/MACHINE:X64)" for all projects. </li>
<li> Remove the projects glib-compile-schemas and gsettings. There will not be needed and does not compile.</li>
+
<li> Open menu <tt>View, Properties manager</tt> and expand INSTALL project, go to Release|Win32; glib.props; select properties, in User macros change <tt>CopyDir</tt> and <tt>GlibEtcInstallRoot</tt> from <tt>..\..\..\..\..\vs10\$(Platform)</tt> to <tt>..\..\..\</tt>
 
<li> Build target INSTALL </li>
 
<li> Build target INSTALL </li>
 
</ul>
 
</ul>
 
</li>
 
</li>
<li> Copy the following files to <tt><SDKHOME>\glib-2.28.8\include</tt> and <tt><SDKHOME>\glib-2.28.8\lib</tt>: (to be updated) </li>
+
<li> Copy the all lib files from <tt><SDKHOME>\glib-2.28.8\build\Win32\vs10\Release\Win32\bin</tt> (for 64-bit version in <tt><SDKHOME>\glib-2.28.8\build\Win32\vs10\Release\x64\bin</tt>) and <tt><SDKHOME>\glib-2.28.8\lib</tt>.</li>
 
</ol>
 
</ol>
  
Line 1,064: Line 1,065:
  
 
<ol>
 
<ol>
<li> Pull from subversion: svn://svn.berlios.de/lensfun </li> to <tt><SDKHOME>\lensfun-svn</tt>
+
<li> Pull from subversion: svn://svn.berlios.de/lensfun to <tt><SDKHOME>\lensfun-svn</tt> </li>
 +
<ul>
 +
<li> In Explorer go to <tt><SDKHOME></tt>, open context menu (right mouse button), select "SVN Checkout", give URL: <tt>svn://svn.berlios.de/lensfun</tt> and path <tt><SDKHOME>\lensfun-svn</tt> </li>
 +
</ul>
 
<li> Build library with CMake  
 
<li> Build library with CMake  
 
<ul>
 
<ul>
 +
<li> Start CMake-GUI </li>
 +
<li> Point "Where is the source code:" to <tt><SDKHOME>\lensfun-svn</tt> </li>
 +
<li> Point "Where to build:" to <tt><SDKHOME>\build-lensfun</tt> </li>
 +
<li> Click Configure and select "Visual Studio 10" (or "Visual Studio 10 Win64" for 64-bit) </li>
 
<li> Set option <tt>BUILD_STATIC</tt> to on/TRUE </li>
 
<li> Set option <tt>BUILD_STATIC</tt> to on/TRUE </li>
 
<li> Check <tt>GLIB2_BASE_DIR</tt> and set to your GLIB2 directory. </li>
 
<li> Check <tt>GLIB2_BASE_DIR</tt> and set to your GLIB2 directory. </li>
 +
<li> Click Configure again, then Generate </li>
 
</ul>
 
</ul>
 
</li>
 
</li>
<li> Open generated project file and build target INSTALL </li>
+
<li> Open generated project file lensfun.sln in <tt><SDKHOME>\build-lensfun</tt>, select "Release" in the Solution Configuration pull-down menu and build target INSTALL </li>
 
</ol>
 
</ol>
  

Revision as of 17:32, 29 September 2013

Hugin depends on different components like libraries and tools, which are not available on a common Windows system. All these components can be combined to a Hugin Software Development Kit (SDK). This article will eventually give step-by-step instructions to build such SDK for Hugin using Microsoft Visual C++ 2010 (MSVC 2010) Express Edition and precompiled dependencies.

Note: Work in Progress: The SDK, Hugin and enblend have all been built successfully with MSVC 2010 Express, on Windows 7 x64 Professional, as of July 6, 2010. However, the instructions below are probably not complete, and may be specific to Windows 7. This article has been copied wholesale from Hugin SDK (MSVC 2008), and has been updated as the steps were successfully completed.

This article will construct native 32-bit and 64-bit versions. When appropriate, steps that only apply to the 32-bit or 64-bit versions will be noted as (32-bit) or (64-bit), and you can safely ignore them if you are not targeting that particular version. In order to compile a 64-bit version of the Hugin SDK, one does not need a 64-bit computer. However, if they wish to test or debug the binaries, or for some projects (such as OpenEXR) which execute compiled binaries as part of their build step, this will not necessarily be possible on Win32.

First of all an overview is given over the contents of the SDK and the tools that are necessary to build the SDK.

The build steps for each component are written like a walk-through and annotated on the end of each section.

Maybe some of the described tools and packages, especially those fetched from Mercurial (Hg) repository, will change over time and/or become obsolete. Hence it is likely that some steps will become invalid or won't work any more.

The SDK is structured so that each component resides in its own subdirectory. This approach is different to other platforms like Linux, where some common directories are available to store include files, libraries and applications. The files of a component are spread over all these directories. Both approaches to structure the files in a file system have its assets and drawbacks.

The base directory of the SDK is denoted as <SDKHOME> in this article. Replace <SDKHOME> by directory name where you store the SDK on your system. In the examples <SDKHOME> is replaced by the directory name D:\usr\src\SDK.

Prerequisites

To build the SDK some tools are required that are listed in the table below. Download the tools and install them. The destination directory of each tool is arbitrary. If you are uncertain, choose the default given in the setup dialog of each tool.

Tool Description
Microsoft Visual C++ 2010 Express Edition Compiler, Debugger and IDE
Visit Download page
If compiling for 64-bit, you will need to download the SDK, listed next.
(x64 Only) Microsoft Windows SDK for Windows 7 and .NET Framework 4 x64 Compiler, Libraries, and Headers
Visit [1]
When installing, make sure to include the Visual C++ compilers for x64 (under Developer Tools) and the Header Files and x64 libraries (under Windows Headers and Libraries). Optionally consider installing all of the SDK, as it makes compiling generally easier.
CMake 2.8.1 (2010-04-05) Generator of solution and project files for MSVC 2010
Visit Download page or download cmake-2.8.1-win32-x86.exe
Leave default 'Don't add Cmake to system path'
Follow the note on the download page to replace CMakeVS10FindMake.cmake
(skip) TortoiseSVN 1.6.1.16129 (2009-02-13) (skip) Tool to handle source codes in Subversion repositories
Visit Download page or download
TortoiseSVN-1.6.1.16129-win32-svn-1.6.1.msi (32-bit) or
TortoiseSVN-1.6.1.16129-x64-svn-1.6.1.msi (64-bit)
TortoiseHg 1.0.4 (2010-06-11) Tool to handle source codes in Mercurial repositories
Visit Download page
Choose x64 if appropriate for you.
7-Zip 4.65 (2009-02-03) Tool to decompress the source packages
Visit Download page or download 7z465.exe (32-bit) or 7z465-x64.msi (64-bit)
(skip - not required for Enblend 4.0) Java SE Development Kit 6 Update 20 (skip) Java Development Kit (JDK)
Visit Download page

Contents of the Hugin SDK

Precompiled Version (32-bit only)

This is what we are working towards: For those who want to avoid to build the whole SDK from scratch, the last available precompiled SDK is for MSVC 2008, for an older version of Hugin.

Precompiled Hugin SDK (Win32)
Hugin-SDK-20090509-win32.exe (76 MiB, 2009-05-09)

Building from Source

The contents of the Hugin SDK is shown in the following table. Download the packages, except the packages fetched from Hg/Subversion repository.

Directory Description (Website)
Download package (Date of the package)
autopano-sift-C Autopano-SIFT-C (http://hugin.sourceforge.net/)
Mercurial repository

http://hugin.hg.sourceforge.net:8000/hgroot/hugin/autopano-sift-C from Hugin_Compiling_Ubuntu(Note January 2010 / May 2010: Currently the autopano-sift-C SVN trunk, as well as Hg default tip, is unstable, use the 2.5.1 release tarball instead)
2011: With a working cpfind this is not necessary any more.

boost_1_43_0 Boost C++ libraries 1.43.0

(http://www.boost.org/)
[http://sourceforge.net/projects/boost/files/boost/1.43.0/boost_1_43_0.7z/download boost_1_43_0.7z]

Deploy
OpenEXR
OpenEXR library 1.6.1 and IlmBase libraries 1.0.1 (http://www.openexr.com/)
ilmbase-1.0.1.tar.gz (2007-10-22)
openexr-1.6.1.tar.gz (2007-10-22)
enblend-enfuse-4.1.1 Enblend 4.1.1 and Enfuse 4.1.1 (http://enblend.sourceforge.net/)
32-Bit 64-Bit
enblend-enfuse-4.1.1-win32.zip (2013-02-15) enblend-enfuse-4.1.1-win64.zip (2013-02-15)
exiftool ExifTool 9.37 (http://www.sno.phy.queensu.ca/~phil/exiftool)
exiftool-9.37.zip (2013-09-14)
exiv2-0.20.0 Exiv2 C++ library 0.20 (http://www.exiv2.org/)
exiv2-0.20.tar.gz (2010-05-30)
expat-2.0.1 Expat XML Parser library 2.0.1 (http://sourceforge.net/projects/expat/)
expat-2.0.1.tar.gz (2007-06-05)
gettext GNU gettext 0.13.1 and iconv library 1.9.1 (http://www.gnu.org/)
32-Bit (skip - need binaries only) 64-Bit
(skip - use 32bit binaries)
glew OpenGL Extension Wrangler Library (GLEW) 1.5.1 (http://glew.sourceforge.net/)
glew-1.5.1-src.zip (2008-11-03)
libpano\pano13 Panorama Tools and pano13 library (http://panotools.sourceforge.net/)
libpano13-2.9.18.tar.gz 2011-05-02
(autopano-sift-c only) libxml2-2.7.3 XML C parser and toolkit (http://www.xmlsoft.org/)
libxml2-sources-2.7.3.tar.gz (2009-01-18)
UnxUtils (inutile si cygwin est installé) Utilitaires GNU portés sur plateforme Windows 32 bits (http://sourceforge.net/projects/unxutils/)
UnxUtils.zip (2007-03-01)
wxWidgets-2.8.11 wxWidgets cross-platform GUI C++ framework 2.8.11 (http://www.wxwidgets.org/)
wxMSW-2.8.11.zip (2009-03-17)
freeglut_2.6.0 Freeglut (http://freeglut.sourceforge.net/index.php)
freeglut-2.6.0.tar.gz
make_3.81 GNU make 3.81 (http://www.gnu.org/software/make/)
make-3.81.tar.gz
This package replaces UnxUtils inside hugin.
Templatized C++ Command Line Parser 1.2.0 tclap (http://tclap.sourceforge.net/)
tclap-1.2.0.tar.gz
GLib glib libary from GTK+ (http://www.gtk.org/)
Download site
I don't know, if the precompiled version work with lensfun/Hugin. Use the source distribution.
Lensfun lensfun library for reading/writing to lens database (http://lensfun.berlios.de/)
lensfun-0.2.7.tar.bz2 (2013-02-10)
Additional files only necessary for building a 64-bit SDK
Directory Description (Website)
Download package (Date of the package)
(64-bit Enblend only) libxmi-1.2-1 GNU libxmi 2-D rasterization library (Win32 port) (http://gnuwin32.sourceforge.net)
libxmi-1.2-1-src.zip (2004-04-16)
(64-bit Enblend only) STLport-5.2.1 STLport Standard Library (http://stlport.sourceforge.net/)
STLport-5.2.1.tar.gz (2008-12-10)
(64-bit Enblend only) lcms-1.18 LittleCms Color management library (http://www.littlecms.com)
lcms-1.18a.zip (2009-04-19)

2.0 has been released, but will require code updates to enblend.

Additional files only necessary for building Hugin Setup (NSIS Installer)
Directory Description (Website)
Download package (Date of the package)
NSIS Nullsoft Scriptable Install System (http://nsis.sourceforge.net/)
nsis-2.46-setup.exe (2009-12-06)

In the following subsections each component is discussed in detail. The order of the subsections seems random, but I describe the precompiled packages first, followed by the big packages, where some of the small packages depend on.

The decompress step of each component contains seemingly inconsistent namings of destination directories. These were chosen mostly to satisfy Cmake. To check the right locations, each result section of every component's description contains a summary of the expected files.

freeglut and gnu make were added after the 2009 SDK was constructed.


Diff Files

In order to make compilation simple, a series of patch files are included below that contain all the necessary changes, not only to compile the SDK, but to optionally compile an x64 version of the SDK. When directed, you will need to apply the patch file specified. If you are compiling for x64, there may be additional patches you need to apply.

The download link for the patches is https://bugs.launchpad.net/hugin/+bug/679695/+attachment/1741338/+files/hugin_patches.zip

In order to apply a patch, you will first have needed to follow directions for the UnxUtils step. You cannot apply any patches before that step.

Alternative: If you already have the Cygwin environment installed, you can install the 'patch' module and perform the patch commands at a cygwin prompt. Otherwise, UnxUtils is much simpler. However, cygwin patch seems to set the permissions of changed files so they can't be modified by normal users, so after patching do this:
Right-click the folder, Properties, Security tab, Advanced, Change Permissions, check Replace all child object perms...., click OK, OK, OK.

To apply a patch, follow these directions:

  1. Start a Command Prompt by choosing Start -> Run and typing in "cmd.exe"
  2. On the Command Prompt, change directory to <SDKHOME>
    Example
    C:\Program Files\Microsoft\Windows SDK\v7.1>d:
    
    D:>cd \usr\src\SDK
    
    D:\usr\src\SDK>
    
  3. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key, substituting <SDKHOME> where appropriate:
    set PATH=%PATH%;<SDKHOME>\UnxUtils\usr\local\wbin
    
  4. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key, substituting <PATCHFILE> with the name of the patch file to apply:
    patch -p 0 -i <PATCHFILE>
    

    NOTE: On Vista and later systems, the filename "patch.exe" is a protected file name which will always result in a UAC prompt if the file does not include a manifest (which UnxUtils version does not). This can be worked around by copying the file <SDKHOME>\UnxUtils\usr\local\wbin\patch.exe to another file not containing the name, such as <SDKHOME>\UnxUtils\usr\local\wbin\apply_diff.exe. Then substitute the command 'patch' in the above command with 'apply_diff'

Result

If everything worked, you should see a list of filenames that were patched. Example

D:\usr\src\SDK>patch -p 0 -i libiconv-1.9.1.diff
patching file 'libiconv-1.9.1/srclib/error.c'

D:\usr\src\SDK>

If there was an error, you may wish to consult the Hugin SDK (MSVC 2008) Patches page for instructions on what changes were contained in the patch.

UnxUtils

  1. Create the directory <SDKHOME>\UnxUtils
  2. Decompress the file UnxUtils.zip to created directory <SDKHOME>\UnxUtils

Result

The applications reside in <SDKHOME>\UnxUtils\bin and <SDKHOME>\UnxUtils\usr\local\wbin

ExifTool

  1. Create the directory <SDKHOME>\exiftool
  2. Decompress the file exiftool-8.23.zip to <SDKHOME>\exiftool
  3. Rename the file exiftool(-k).exe to exiftool.exe

Result

The application resides in <SDKHOME>\exiftool

GetText

Binary only, 32-bit binaries work for a 64-bit build.

  1. Create the directory <SDKHOME>\gettext
  2. Decompress the following files to created directory <SDKHOME>\gettext
    • gettext-runtime-0.13.1.bin.woe32.zip
    • gettext-tools-0.13.1.bin.woe32.zip
    • libiconv-1.9.1.bin.woe32.zip

Result

The applications reside in <SDKHOME>\gettext\bin

The include files reside in <SDKHOME>\gettext\include

The libraries (unused) reside in <SDKHOME>\gettext\lib

STLport (64-bit Enblend Only)

  1. Decompress the file STLport-5.2.1.tar.gz to directory <SDKHOME>
  2. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v7.1 -> Windows SDK v7.1 Cmd Prompt
  3. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
    setenv /Release /x64 /xp
    

    It should now refresh and say

    Setting SDK environment relative to <path where you installed the SDK>
    Targeting Windows XP x64 RELEASE
    
  4. On the command prompt, change directory to <SDKHOME>\STLport-5.2.1
    Example
    C:\Program Files\Microsoft\Windows SDK\v6.1>d:
    
    D:>cd \usr\src\SDK\STLport-5.2.1
    
    D:\usr\src\SDK\STLport-5.2.1>
    
  5. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key:
    configure msvc9 --with-static-rtl
    cd build/lib
    nmake clean install
  6. Compilation will fail, complaining about
    stlport\stl/_cstdlib.h(158) : error C2084: function '__int64
    abs(__int64)' already has a body 
    This indicates that the compiler didn't like the declaration on line 158 of <SDKHOME>\STLport-5.2.1\stlport\stl\_cstdlib.h - comment that line out, and compile again. It should succeed.
  7. Close the Windows SDK command prompt window

Result

The includes reside in <SDKHOME>\STLport-5.2.1\stlport
The libraries reside in <SDKHOME>\STLport-5.2.1\lib

lcms-1.18 (64-bit Enblend Only)

  1. Decompress the file lcms-1.18a.tar.gz to directory <SDKHOME>
  2. Apply the lcms-1.18.diff patch
  3. Open the file <SDKHOME>\lcms-1.18\Projects\VC2008\lcms.sln. Allow conversion.
  4. Select project lcms, right-click Properties
  5. Select "Release" in the Solution Configuration pull-down menu. Select "x64" in the Solution Platform pull-down menu
  6. Select project lcms in Solution Explorer, and then choose Build > Project Only > Build Only lcms
  7. changes to output file and intermediate directory for x64
  8. Close Visual Studio C++ 2010 Express

Result

The library resides in <SDKHOME>\lcms-1.18\Lib\MS-x64

Note
During build process temporary object files are stored in following directories
  • <SDKHOME>\lcms-1.18\Projects\VC2008\LibDebug
  • <SDKHOME>\lcms-1.18\Projects\VC2008\LibRelease

Both directories may be deleted to save disk space.

libxmi-1.2.1 (64-bit Enblend Only)

  1. Open the file libxmi-1.2-1.src.zip in 7-Zip
  2. Open the "src" folder by double-clicking
  3. Open the "libxmi" folder by double-clicking
  4. Open the "1.2" folder by double-clicking
  5. Extract "libxmi-1.2" to the directory <SDKHOME>
  6. Apply the libxmi-1.2.diff patch
  7. Open libxmi.vcproj. Allow conversion.
  8. Set default Output/Intermediate options for x64
  9. Build libxmi, x64 Debug and Release

Result

The libxmi-1.2 sources now reside in <SDKHOME>\libxmi-1.2 The libxmi-1.2 libs now reside in <SDKHOME>\libxmi-1.2\x64\Debug or Release

wxWidgets

  1. Decompress the file wxMSW-2.8.11.zip to directory <SDKHOME>
  2. Rename the directory <SDKHOME>\wxMSW-2.8.11 to <SDKHOME>\wxWidgets-2.8.11
  3. Apply the wxWidgets-2.8.11.diff patch Hugin SDK (MSVC 2008) Patches#wxWidgets
  4. 32-Bit Directions 64-Bit Directions
    To open a Visual Studio command prompt choose Start > Programs > Microsoft Visual Studio 2010 Express Edition > Visual Studio Command Prompt (2010)
    1. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v1.1 -> Windows SDK 7.1 Command Prompt
    2. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
      setenv /Release /x64 /xp
      

      It should now refresh and say

      Setting SDK environment relative to <path where you installed the SDK>
      Targeting Windows XP x64 Release
      
  5. On command prompt change directory to <SDKHOME>\wxWidgets-2.8.11\build\msw
    Example
    C:\Program Files\Microsoft Visual Studio 10.0\VC>d:
    
    D:\>cd \usr\src\SDK\wxWidgets-2.8.11\build\msw
    
    D:\usr\src\SDK\wxWidgets-2.8.11\build\msw>
    
  6. Enter each of the following two commands without any line break and press the Return key
    32-Bit Directions
    nmake -f makefile.vc BUILD=debug UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    nmake -f makefile.vc BUILD=release UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    

    64-Bit Directions

    nmake -f makefile.vc BUILD=debug TARGET_CPU=AMD64 UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    nmake -f makefile.vc BUILD=release TARGET_CPU=AMD64 UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    
  7. Close the Windows SDK command prompt window

Result

The include files reside in <SDKHOME>\wxWidgets-2.8.11\include and its subdirectories

Hugin also depends on following files

  • <SDKHOME>\wxWidgets-2.8.11\src\jpg\*.h
  • <SDKHOME>\wxWidgets-2.8.11\src\jpg\jconfig.vc
  • <SDKHOME>\wxWidgets-2.8.11\src\png\*.h
  • <SDKHOME>\wxWidgets-2.8.11\src\tiff\*.h
  • <SDKHOME>\wxWidgets-2.8.11\src\zlib\*.h

The libraries reside in <SDKHOME>\wxWidgets-2.8.11\lib\vc_lib and/or <SDKHOME>wxWidgets-2.8.11\lib\vc_amd64_lib

Note
During build process temporary object files are stored in following directories
32-Bit 64-Bit
  • <SDKHOME>\wxWidgets-2.8.11\build\msw\vc_mswu
  • <SDKHOME>\wxWidgets-2.8.11\build\msw\vc_mswud
  • <SDKHOME>\wxWidgets-2.8.11\build\msw\vc_mswu_amd64
  • <SDKHOME>\wxWidgets-2.8.11\build\msw\vc_mswud_amd64

Both directories may be deleted to save disk space.

Boost

  1. Decompress the file boost_1_43_0.7z to directory <SDKHOME>
  2. (skip) Decompress the file boost-jam-3.1.17-1-ntx86.zip to an arbitrary directory and copy the application bjam.exe to <SDKHOME>\boost_1_39_0
  3. Open a Visual Studio command prompt, like you did with wxWidgets
  4. On command prompt change directory to <SDKHOME>\boost_1_43_0
    Example
    C:\Dokuments and Settings\Guido>d:
    
    D:\>cd \usr\src\SDK\boost_1_43_0
    
    D:\usr\src\SDK\boost_1_43_0>
    
  5. Enter the command 'bootstrap' to build bjam.exe
  6. Enter the following command without line breaks and press Return key
    32-Bit Directions 64-Bit Directions
    bjam --with-date_time --with-thread --with-system --with-signals --with-regex --with-iostreams --with-filesystem --with-serialization toolset=msvc variant=debug variant=release link=static threading=multi runtime-link=static stage
    

    After bjam.exe finishes a statement like the following should be printed in the command prompt window

    ...updated 56 targets...
    
    d:\usr\src\SDK\boost_1_43_0>
    
    bjam --with-date_time --with-thread --with-system --with-signals --with-regex --with-iostreams --with-filesystem --with-serialization toolset=msvc variant=debug variant=release link=static threading=multi runtime-link=static address-model=64 stage
    

    After bjam.exe finishes a statement like the following should be printed in the command prompt window

    ...updated 44 targets...
    
  7. To build both 32-bit and 64-bit directions, rename boost_1_43_0\stage\lib directory to lib_win32 after building 32-bit, and to lib_x64 after building the 64-bit targets
  8. Close the Windows command prompt window

Result

The include files reside in <SDKHOME>\boost_1_43_0 and its subdirectory boost

The libraries reside in <SDKHOME>\boost_1_43_0\stage\lib (or lib_win32 and lib_x64)

Notes
  • During build process temporary files are generated in <SDKHOME>\boost_1_43_0\bin.v2. This directory may be deleted to save disk space.
  • Hugin needs only a subset of the Boost libraries, thus only these required libraries have to be built.
    If you want to build all Boost libraries enter following command on the Windows command prompt instead of the command described above and press Return key.
    bjam -–build-type=complete toolset=msvc stage
    

    There are about 7GB disc space needed during build of all libraries (3.5GB for libraries and the same amount for the temporary files).

  • The Boost include files are typically included by a statement like
    #include "boost/whatever.hpp"
    Therefore the base directory of the Boost include files is <SDKHOME>\boost_1_43_0
  • Only the following libraries are needed to build a release version of Hugin:
    • libboost_date_time-vc100-mt-s.lib
    • libboost_thread-vc100-mt-s.lib

    The files with "gd" in the filename, e.g. libboost_thread-vc100-mt-sgd-1_43.lib, are the debug libraries. The library files without "-1_43" suffix are automatically generated copies of the libraries with version suffix. They are used by CMake to detect the library directory.

OpenEXR

OpenEXR depends on following SDK component:

  • wxWidgets

Prepare this component before OpenEXR.

  1. Create the directory <SDKHOME>\OpenEXR
  2. Decompress the file ilmbase-1.0.1.tar.gz to created directory <SDKHOME>\OpenEXR
  3. Decompress the file openexr-1.6.1.tar.gz to the same directory <SDKHOME>\OpenEXR
    After decompress there should only exist the two directories ilmbase-1.0.1 and openexr-1.6.1 in <SDKHOME>\OpenEXR
  4. Apply the OpenEXR.diff patch Hugin SDK (MSVC 2008) Patches#OpenEXR
  5. Open solution file <SDKHOME>\OpenEXR\ilmbase-1.0.1\vc\vc8\IlmBase\IlmBase.sln
  6. Allow conversion to proceed. TODO is Batch Build better?
  7. Select Debug in Solutions Configuration pull-down menu, and then choose Build > Build Solution
  8. Select Release in Solutions Configuration pull-down menu, and then choose Build > Build Solution
  9. TODO is 64-bit needed? Change General .. Platform Toolset to Win 7.1 SDK for all x64 projects.
  10.  ? For 64-bit, find the lines "HALF_EXPORT_CONST half::uif half::_toFloat[1 << 16] =" and "HALF_EXPORT_CONST unsigned short half::_eLut[1 << 9] =" in half.cpp and append "{};" to the end of each of them.
  11. Open solution file <SDKHOME>\OpenEXR\openexr-1.6.1\vc\vc8\OpenEXR\OpenEXR.sln
  12. TODO update reference for wxWidgets-2.8.11 (from wxWidgets-2.8.10 to wxWidgets-2.8.11)
  13. Choose Build > Batch Build
  14. Select Build for Project IlmImf with Solution Config
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  15. Click Build
  16. Close Visual C++ 2010 Express

Result

The include files reside in <SDKHOME>\Deploy\include

The libraries reside in <SDKHOME>\Deploy\lib\Debug and <SDKHOME>\Deploy\lib\Release for win32, <SDKHOME>\Deploy\lib\x64\Debug and <SDKHOME>\Deploy\lib\x64\Release for x64.

Enblend and Enfuse

32-Bit Directions 64-Bit Directions
  1. Decompress the file enblend-enfuse-4.0.zip to directory <SDKHOME>
Enblend & Enfuse depend on the following SDK components:
  • wxWidgets
  • OpenEXR
  • lcms
  • STLport
  • boost
  • libxmi

Prepare these components before Enblend & Enfuse.

  1. Decompress the file enblend-enfuse-4.0.tar.gz to directory <SDKHOME>
    After decompression, you should now have a folder <SDKHOME>\enblend-enfuse-4.0
  2. Alternate: get enblend from the Hg repository. Needed 7 July 2010 to get CMakeLists.txt
  3. Run Cmake, use <SDKHOME>\enblend-enfuse-4.0 as the source, and <SDKHOME>\enblend-build-x64 as the build destination, and MSVC 2010 x64 as the compiler.
  4. All the dependencies will be NOT FOUND or find the win32 versions - change to x64 versions.
  5. Open the file <SDKHOME>\enblend-build-x64\enblend.sln
  6. If one checked ENABLE_GPU in CMake, one must add FREEGLUT_STATIC to the preprocessor definitions of the enblend and enfuse projects.
  7. Select Release in Solutions Configuration pull-down menu, choose x64 in the Solutions Platform pull-down menu, and then choose Build > Build Solution
  8. Close Visual C++ 2010 Express

Result

The applications reside in <SDKHOME>\enblend-enfuse-4.0 for 32-bit,
or <SDKHOME>\enblend-build-x64 for 64-bit.

Expat

  1. Decompress the file expat-2.0.1.tar.gz to directory <SDKHOME>
  2. Apply the expat-2.0.1.diff patch Hugin SDK (MSVC 2008) Patches#expat
  3. Open the file <SDKHOME>\expat-2.0.1\Source\expat.sln
  4. Allow conversion to proceed.
  5. Right-click expat_static, and choose Properties
  6. Under Configuration Properties, General, change Output Dir to .\..\$(Platform)\bin\$(Configuration)\
  7. Change Intermediate Dir to .\..\$(Platform)\tmp\$(Configuration)_static\
  8. Change Target Name to libexpatMT
  9. Configuration Properties, Librarian, Output File, change Output File to inherit from parent or project defaults
  10. Configuration Properties, C++, Output Files, change ASM List Location, Object File Name, and Program DB File Name to inherit from parent or project defaults
  11. Choose Build > Batch Build
  12. Select Build for Project expat_static with
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  13. Click Build
  14. Close Visual C++ 2010 Express

Result

The include files reside in <SDKHOME>\expat-2.0.1\lib

The libraries reside in <SDKHOME>\expat-2.0.1\win32\bin\Debug and <SDKHOME>\expat-2.0.1\win32\bin\Release
<SDKHOME>\expat-2.0.1\x64\bin\Debug and <SDKHOME>\expat-2.0.1\x64\bin\Release

Exiv2

Exiv2 depends on following SDK components:

  • wxWidgets
  • GetText
  • Expat

Prepare these components before Exiv2.

  1. Decompress the file exiv2-0.20.tar.gz to directory <SDKHOME>
  2. Apply the exiv2-0.20.diff patch Hugin SDK (MSVC 2008) Patches#exiv2
  3. (64-bit Only)Apply the exiv2-0.20.x64.diff patch
  4. Open solution file <SDKHOME>\exiv2-0.20\msvc\exiv2.sln
  5. In the Solution Explorer, select "exiv2lib"
  6. Right-click exiv2lib, and choose Properties, select All Configurations, and All Platforms
  7. Under Configuration Properties, General, change Output Dir and Intermediate Dir to inherit from parent or project defaults
  8. Change Target Name to exiv2
  9. Configuration Properties, C++, General, change Treat Warnings as Errors to No
  10. Configuration Properties, Librarian, Output File, change Output File to inherit from parent or project defaults
  11. Right-click exiv2lib, and choose Properties, select All Configurations, and All Platforms
  12. Under Configuration Properties, General, change Output Dir and Intermediate Dir to inherit from parent or project defaults
  13. TODO update reference for wxWidgets-2.8.11 (from wxWidgets-2.8.10 to wxWidgets-2.8.11)
  14. Choose Build > Batch Build
  15. Select Build for Project exiv2lib with
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  16. Click Build
  17. Close Visual C++ 2010 Express
  18. Create the directory <SDKHOME>\exiv2-0.20\msvc\lib
  19. Copy the following files to this directory and rename them as specified in Destination column.
    Source Destination
    <SDKHOME>\exiv2-0.20\msvc\bin\Debug\exiv2.lib <SDKHOME>\exiv2-0.20\msvc\lib\exiv2d.lib
    <SDKHOME>\exiv2-0.20\msvc\bin\Release\exiv2.lib <SDKHOME>\exiv2-0.20\msvc\lib\exiv2.lib
    <SDKHOME>\expat-2.0.1\win32\bin\Debug\libexpatMT.lib <SDKHOME>\exiv2-0.20\msvc\lib\libexpatd.lib
    <SDKHOME>\expat-2.0.1\win32\bin\Release\libexpatMT.lib <SDKHOME>\exiv2-0.20\msvc\lib\libexpat.lib
  20. Similar for msvc\lib\x64\

Comment

When using exiv2 0.19 (which works better with bigger files), copy and rename also the following files:

Source Destination
<SDKHOME>\exiv2-0.19\msvc\xmpsdk\Debug\xmpsdk.lib <SDKHOME>\exiv2-0.19\msvc\lib\xmpsdkd.lib
<SDKHOME>\exiv2-0.19\msvc\xmpsdk\Release\xmpsdk.lib <SDKHOME>\exiv2-0.19\msvc\lib\xmpsdk.lib

Similar for msvc\lib\x64\

Result

The include files reside in <SDKHOME>\exiv2-0.20\msvc\include

The libraries reside in <SDKHOME>\exiv2-0.20\msvc\lib and lib\x64

GLEW

  1. Decompress the file glew-1.5.1-src.zip to directory <SDKHOME>
  2. Apply the glew.diff patch Hugin SDK (MSVC 2008) Patches#glew
  3. Open the file <SDKHOME>\glew\build\vc6\glew.sln
  4. Let the conversion wizard run.
  5. (64-bit) For the glew_static project, right-click Properties, for each x64 configuration, change:
    1. Configuration Properties, General, Intermediate Dir, change .\static/debug\ to .\static\$(Platform)\debug\
    2. Configuration Properties, Librarian, Output File, change ../../lib/glew32sd.lib to ../../lib/glew64sd.lib and change Target Machine to X64
    3. Configuration Properties, C++, Output Files, change ASM List Location, Object File Name, and Program DB File Name to inherit from parent or project defaults
  6. Choose Build > Batch Build
  7. Select Build for Project glew_static with Solution Config
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  8. Click Build
  9. Close Visual C++ 2010 Express

Result

The include files reside in <SDKHOME>\glew\include

The libraries reside in <SDKHOME>\glew\lib

Note
The GLEW include files are typically included by a statement like
#include "GL/glew.h"
Therefore the base directory of the GLEW include files is <SDKHOME>\glew\include

Panorama Tools

Panorama Tools depends on following SDK component:

  • wxWidgets

Prepare this component before Panoroma Tools.

  1. Set one windows environment variables:
    • Set variable WXWIDGETS_HOME to wxWidgets base folder <SDKHOME>\wxWidgets-2.8.11
    • Alternative: fix the LocalDefs.vsprops file next to the .sln file to point to wxWidgets base folder <SDKHOME>\wxWidgets-2.8.11. This can be changed inside MSVC: View .. Property Manager, pano13 LocalDefs .. Common Properties .. User Macros

    For changed environment variables to take effect you may have to logout and login.

  2. Create the directory <SDKHOME>\libpano\pano13
  3. In explorer right-click on created directory <SDKHOME>\libpano\pano13
  4. , and then choose SVN Checkout from the shortcut menu. The Checkout dialog appears.
  5. In "URL of repository" field enter following address:
    https://panotools.svn.sourceforge.net/svnroot/panotools/trunk/libpano
    
  6. Click OK
  7. After checkout has finished click OK
  8. Open solution file <SDKHOME>\libpano\pano13\libpano.sln, let the upgrade wizard run.
  9. Select all projects, then right-click and choose Properties, select All Configurations, and All Platforms
  10. Under Configuration Properties, General, change Platform Toolset from v100 to Windows7.1SDK
  11. Under Configuration Properties, General, change Output Dir and Intermediate Dir to $(Configuration)\$(Platform)\ (Note: already done in 2.9.17)
  12. Temporary 2.9.17 fixes: optimize.c, change brackets to quotes, "filter.h" and "adjust.h". Release build, linker, wxWidgets\lib\vc_amd64_lib instead of vc_lib64. Get tools/*.rc from svn. (Sept 7, 2010)
  13. Select your platform in the Solution Platform pull-down menu
  14. Select "Debug CMD" in Solution Configuration pull-down menu
  15. Select project pano13 in Solution Explorer, and then choose Build > Project Only > Build Only pano13
  16. Add to pano13: sys_compat_win.c
  17. Select "Release CMD" in Solution Configuration pull-down menu, and then choose Build > Build Solution (Note: multi-core machines, right click and build each project individually, skipping PTAInterpolate. Avoids log-file write conflict.
  18. Close Visual C++ 2010 Express

Result

The applications reside in <SDKHOME>\libpano\pano13\tools\Release CMD\Win32 or x64

The include files reside in <SDKHOME>\libpano\pano13

The libraries reside in <SDKHOME>\libpano\pano13\Debug CMD\Win32 or x64 and <SDKHOME>\libpano\pano13\Release CMD\Win32 or x64

Note
The applications have to be built in release version only. Therefore only pano13 library has to be built in Debug configuration.

libxml2

Note: required by autopano-sift-c only, not by enblend or hugin. Untested and unchanged from MSVC 2008 version because autopano-sift-c untested.

  1. Decompress the file libxml2-sources-2.7.3.tar.gz to directory <SDKHOME>
  2. 32-Bit Directions 64-Bit Directions
    1. To open a Visual Studio command prompt choose Start > Programs > Microsoft Visual C++ 2008 Express Edition > Visual Studio Tools > Visual Studio 2008 Command Prompt
    1. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v6.1 -> CMD Shell
    2. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
      setenv /Release /x64 /xp
      

      It should now refresh and say

      Setting SDK environment relative to <path where you installed the SDK>
      Targeting Windows XP x64 RELEASE
      
  3. On command prompt change directory to <SDKHOME>\libxml2-2.7.3\win32
    Example
    Setting environment for using Microsoft Visual Studio 2008 x86 tools.
    
    C:\Program Files\Microsoft Visual Studio 9.0\VC>d:
    
    D:\>cd \usr\src\SDK\libxml2-2.7.3\win32 
    
    D:\usr\src\SDK\libxml2-2.7.3\win32>
    
  4. Enter each of the following two commands without any line break and press the Return key.
    cscript configure.js ftp=no http=no iconv=no cruntime=/MT
    nmake -f makefile.msvc libxmla
    

Result

The include files reside in <SDKHOME>\libxml2-2.7.3\include

The libraries reside in <SDKHOME>\libxml2-2.7.3\win32\bin.msvc

Notes
  • During build process temporary object files are generated in directory <SDKHOME>\libxml2-2.7.3\win32\int.a.msvc. This directories may be deleted to save disc space.
  • Hugin does not depend on libxml2 library, but autopano-sift-C. Therefore it is included in this SDK.

autopano-sift-C

Note: Untested and unchanged from MSVC 2008 version because of patent restrictions for U.S.-based author (Aron Helser).
Autopano-SIFT-C depends on following SDK components:

  • libxml2
  • Panorama Tool's pano13 library
  • wxWidgets

Prepare these components before Autopano-SIFT-C.

  1. Create the directory <SDKHOME>\autopano-sift-C-trunk
  2. In explorer right-click on created directory <SDKHOME>\autopano-sift-C-trunk, and then choose SVN Checkout from the shortcut menu. The Checkout dialog appears.
  3. In "URL of repository" field enter following address:
    https://hugin.svn.sourceforge.net/svnroot/hugin/autopano-sift-C/trunk
    
  4. Click OK
  5. After checkout has finished click OK
  6. Start CMake (cmake-gui). The CMake dialog appears.
  7. In "Where is the source code" field enter
    <SDKHOME>\autopano-sift-C-trunk
    
    Alternatively click Browse Source to point to this directory
  8. In "Where to build the binaries" field enter
    <SDKHOME>\autopano-sift-C
    
  9. Click Configure
    If a dialog appears, which asks to create the build directoy, click Yes.
    A dialog appears, where you can specify the generator for the project.
  10. 32-Bit Directions 64-Bit Directions
    Select "Visual Studio 9 2008" and select option "Use default native compilers" Select "Visual Studio 9 2008 Win64" and select option "Use default native compilers"
  11. Click Finish
    In the Name and Value list the entries are shown with red background.
  12. Click Configure
  13. Click Generate
  14. Close CMake
  15. Open solution file <SDKHOME>\autopano-sift-C\autopano-sift-C.sln
  16. Select Release in Solution Configuration pull-down menu, and then choose Build > Build Solution
  17. Select project INSTALL in Solution Explorer, and then choose Build > Project Only > Build Only INSTALL
  18. Close Visual C++ 2008 Express Edition
  19. Copy the directories bin and shared from <SDKHOME>\autopano-sift-C\INSTALL\FILES to <SDKHOME>\autopano-sift-C

Result

The applications reside in <SDKHOME>\autopano-sift-C\bin

The manual pages reside in <SDKHOME>\autopano-sift-C\shared

Note
To save disk space you may delete all files and directories in <SDKHOME>\autopano-sift-C, except the subdirectories bin and shared.

Freeglut

  1. Decompress the file freeglut-2.6.0.tar.gz to directory <SDKHOME>
  2. Open the file <SDKHOME>\freeglut-2.6.0\VisualStudio2008Static\freeglut.sln
  3. Select "Debug" in the Solution Configuration pull-down menu.
  4. Select project freeglut in Solution Explorer, and then choose Build > Project Only > Build Only freeglut
  5. Select "Release" in the Solution Configuration pull-down menu.
  6. Select project freeglut in Solution Explorer, and then choose Build > Project Only > Build Only freeglut
  7. Close Visual Studio C++ 2010 Express

Result

The library resides in <SDKHOME>\freeglut-2.6.0\VisualStudio2008Static\Debug and <SDKHOME>\freeglut-2.6.0\VisualStudio2008Static\Release

GNU Make

  1. Decompress the file make-3.81.tar.gz to directory <SDKHOME>
  2. Open the file <SDKHOME>\make-3.81\make_msvc_net2003.sln (Confirm conversion.)
  3. Select "Release" in the Solution Configuration pull-down menu.
  4. Select project make_msvc.net2003 Solution Explorer, and then choose Build > Project
  5. Close Visual Studio C++ 2010 Express
  6. Rename the file <SDKHOME>\make-3.81\Release\make_msvc.net2003.exe to <SDKHOME>\make-3.81\Release\make.exe

Result

The executable make.exe resides in <SDKHOME>\make-3.81\Release\

(All other files in this directory can be deleted to save space.)

--Created: Aron Helser 16:20, 29 June 2010 (UTC)

Templatized C++ Command Line Parser Library (tclap)

  1. Decompress the file tclap-1.2.0.tar.gz to directory <SDKHOME>\tclap-1.2.0

Result

The include files reside in <SDKHOME>\tclap-1.2.0\include\tclap

Glib library

Needed by the lensfun library

  1. Decompress the file glib-2.28.8.tar.bz2 to directory <SDKHOME>\glib-2.28.8
  2. Open project file in glib\2.28.8\build\win32\vs10\
  3. Select "Release" in the Solution Configuration pull-down menu.
  4. 64-bit only: Select "x64" in the Platform pull-down menu.
  5. Do the following modifications:
    • Remove the projects glib-compile-schemas, glib-genmarshal, gsettings, gspawn-win32-helper, gspawn-win32-helper-console and testglib. They are not needed.
    • Change type to "static libary (.lib)" for all projects.
    • Change run-time library to "Multi-threaded /MT" for all projects.
    • Project gio: Replace preprocessor _USRDLL directive with GIO_STATIC_COMPILATION
    • Project glib, gmodule, gthread: Replace preprocessor _USRDLL directive with GLIB_STATIC_COMPILATION
    • Project gobject: Replace preprocessor _USRDLL directive with GOBJECT_STATIC_COMPILATION
    • Start building. It will create some config file and will then fail with error messages regarding intl.h
    • Open <SDKHOME>\glib-2.28.8\config.h, comment out line 29: // #define ENABLE_NLS 1
    • Project gio: Add path to zlib includes in wxWidgets to search path: <SDKHOME>\wxWidgets-x.x.x\src\zlib
    • 64-bit only: Change target machine to "MachineX64 (/MACHINE:X64)" for all projects.
    • Open menu View, Properties manager and expand INSTALL project, go to Release|Win32; glib.props; select properties, in User macros change CopyDir and GlibEtcInstallRoot from ..\..\..\..\..\vs10\$(Platform) to ..\..\..\
    • Build target INSTALL
  6. Copy the all lib files from <SDKHOME>\glib-2.28.8\build\Win32\vs10\Release\Win32\bin (for 64-bit version in <SDKHOME>\glib-2.28.8\build\Win32\vs10\Release\x64\bin) and <SDKHOME>\glib-2.28.8\lib.

Result

The include files reside in <SDKHOME>\glib-2.28.8\include, the libraries in <SDKHOME>\glib-2.28.8\lib

Lensfun library

  1. Pull from subversion: svn://svn.berlios.de/lensfun to <SDKHOME>\lensfun-svn
    • In Explorer go to <SDKHOME>, open context menu (right mouse button), select "SVN Checkout", give URL: svn://svn.berlios.de/lensfun and path <SDKHOME>\lensfun-svn
  2. Build library with CMake
    • Start CMake-GUI
    • Point "Where is the source code:" to <SDKHOME>\lensfun-svn
    • Point "Where to build:" to <SDKHOME>\build-lensfun
    • Click Configure and select "Visual Studio 10" (or "Visual Studio 10 Win64" for 64-bit)
    • Set option BUILD_STATIC to on/TRUE
    • Check GLIB2_BASE_DIR and set to your GLIB2 directory.
    • Click Configure again, then Generate
  3. Open generated project file lensfun.sln in <SDKHOME>\build-lensfun, select "Release" in the Solution Configuration pull-down menu and build target INSTALL

Result

All necessary files reside in <SDKHOME>\lensfun

Nullsoft Scriptable Install System (NSIS)

Note: Only needed to build Hugin Setup installer

  1. Run the NSIS installer, nsis-2.46-setup.exe, installing to the default location.

Result

NSIS should be installed to <DRIVE>\Program Files\NSIS