Difference between revisions of "Hugin SDK (MSVC 2008)"

From PanoTools.org Wiki
Jump to: navigation, search
(tclap)
(Add Compiling category)
 
Line 1,004: Line 1,004:
  
 
[[Category:Software:Hugin]]
 
[[Category:Software:Hugin]]
 +
[[Category:Software:Hugin:Compiling]]
 
[[Category:Software:Platform:Windows]]
 
[[Category:Software:Platform:Windows]]

Latest revision as of 23:30, 16 July 2011

Hugin depends on different components like libraries and tools, which are not available on a common Windows system. All these components can be combined to a Hugin Software Development Kit (SDK). This article gives step-by-step instructions to build such SDK for Hugin using Microsoft Visual C++ 2008 (MSVC 2008) Express Edition and precompiled dependencies.

While this article is designed for developing a native 32-bit version, additional instructions are provided so that a 64-bit version of the Hugin SDK can be compiled. When appropriate, steps that only apply to the 32-bit or 64-bit versions will be noted as (32-bit) or (64-bit), and you can safely ignore them if you are not targeting that particular version. In order to compile a 64-bit version of the Hugin SDK, one does not need a 64-bit computer. However, if they wish to test or debug the binaries, or for some projects (such as OpenEXR) which execute compiled binaries as part of their build step, this will not necessarily be possible on Win32.

First of all an overview is given over the contents of the SDK and the tools that are necessary to build the SDK.

The build steps for each component are written like a walk-through and annotated on the end of each section.

Maybe some of the described tools and packages, especially those fetched from Subversion (SVN) repository, will change over time and/or become obsolete. Hence it is likely that some steps will become invalid or won't work any more.

The SDK is structured, that each component resides in its own subdirectory. This approach is different to other platforms like Linux, where some common directories are available to store include files, libraries and applications. The files of a component are spread over all these directories. Both approaches to structure the files in a file system have its assets and drawbacks.

The base directory of the SDK is denoted as <SDKHOME> in this article. Replace <SDKHOME> by directory name where you store the SDK on your system. In the examples <SDKHOME> is replaced by the directory name D:\usr\src\SDK.

Prerequisites

To build the SDK some tools are required that are listed in the table below. Download the tools and install them. The destination directory of each tool is arbitrary. If you are uncertain, choose the default given in the setup dialog of each tool.

Tool Description
Microsoft Visual C++ 2008 Express Edition Compiler, Debugger and IDE
Visit Download page
If compiling for 64-bit, you will need to enable Express Edition to compile 64-bit projects.
(x64 Only) Microsoft Windows SDK for Windows Server 2008 and .NET Framework 3.5 x64 Compiler, Libraries, and Headers
Visit [1]
When installing, make sure to include the Visual C++ compilers for x64 (under Developer Tools) and the Header Files and x64 libraries (under Windows Headers and Libraries). Optionally consider installing all of the SDK, as it makes compiling generally easier.
CMake 2.6.4 (2009-05-05) Generator of solution and project files for MSVC 2008
Visit Download page or download cmake-2.6.4-win32-x86.exe
TortoiseSVN 1.6.1.16129 (2009-02-13) Tool to handle source codes in Subversion repositories
Visit Download page or download
TortoiseSVN-1.6.1.16129-win32-svn-1.6.1.msi (32-bit) or
TortoiseSVN-1.6.1.16129-x64-svn-1.6.1.msi (64-bit)
TortoiseHg 1.0.4 (2010-06-11) Tool to handle source codes in Mercurial repositories
Visit Download page
7-Zip 4.65 (2009-02-03) Tool to decompress the source packages
Visit Download page or download 7z465.exe (32-bit) or 7z465-x64.msi (64-bit)
Java SE Development Kit 6 Update 13 Java Development Kit (JDK)
Visit Download page
Microsoft HTML Help Workshop HTML Help Compiler
Visit Download page for htmlhelp.exe

Contents of the Hugin SDK

Precompiled Version (32-bit only)

For those who want to avoid to build the whole SDK from scratch a precompiled SDK is available.

Precompiled Hugin SDK (Win32)
Hugin-SDK-20090509-win32.exe (76 MiB, 2009-05-09)

Building from Source

The contents of the Hugin SDK is shown in the following table. Download the packages, except the packages fetched from Subversion repository.

Directory Description (Website)
Download package (Date of the package)
autopano-sift-C Autopano-SIFT-C (http://hugin.sourceforge.net/)
Subversion repository
https://hugin.svn.sourceforge.net/svnroot/hugin/autopano-sift-C/trunk
boost_1_39_0 Boost C++ libraries 1.39.0 (http://www.boost.org/)
boost_1_39_0.7z (2009-02-09)
boost-jam-3.1.17-1-ntx86.zip (2008-11-29)
Deploy
OpenEXR
OpenEXR library 1.6.1 and IlmBase libraries 1.0.1 (http://www.openexr.com/)
ilmbase-1.0.1.tar.gz (2007-10-22)
openexr-1.6.1.tar.gz (2007-10-22)
enblend-enfuse-3.2 Enblend 3.2 and Enfuse 3.2 (http://enblend.sourceforge.net/)
32-Bit 64-Bit
enblend-enfuse-3.2.zip (2008-09-09) enblend-enfuse-3.2.tar.gz (2008-09-09)
exiftool ExifTool 7.74 (http://www.sno.phy.queensu.ca/~phil/exiftool)
exiftool-7.74.zip (2009-02-17)
exiv2-0.18.1 Exiv2 C++ library 0.18 (http://www.exiv2.org/)
exiv2-0.18.1.tar.gz (2009-04-06)
expat-2.0.1 Expat XML Parser library 2.0.1 (http://sourceforge.net/projects/expat/)
expat-2.0.1.tar.gz (2007-06-05)
gettext GNU gettext 0.13.1 and iconv library 1.9.1 (http://www.gnu.org/)
32-Bit 64-Bit
glew OpenGL Extension Wrangler Library (GLEW) 1.5.1 (http://glew.sourceforge.net/)
glew-1.5.1-src.zip (2008-11-03)
libpano\pano13 Panorama Tools and pano13 library (http://panotools.sourceforge.net/)
Subversion repository
https://panotools.svn.sourceforge.net/svnroot/panotools/trunk/libpano
libxml2-2.7.3 XML C parser and toolkit (http://www.xmlsoft.org/)
libxml2-sources-2.7.3.tar.gz (2009-01-18)
UnxUtils GNU utilities ported to win32 platform (http://sourceforge.net/projects/unxutils/)
UnxUtils.zip (2007-03-01)
wxWidgets-2.8.10 wxWidgets cross-platform GUI C++ framework 2.8.10 (http://www.wxwidgets.org/)
wxMSW-2.8.10.zip (2009-03-17)
Additional files only necessary for building a 64-bit SDK
Directory Description (Website)
Download package (Date of the package)
(64-bit) libxmi-1.2-1 GNU libxmi 2-D rasterization library (Win32 port) (http://gnuwin32.sourceforge.net)
libxmi-1.2-1-src.zip (2004-04-16)
(64-bit) STLport-5.2.1 STLport Standard Library (http://stlport.sourceforge.net/)
STLport-5.2.1.tar.gz (2008-12-10)
(64-bit) lcms-1.18a LittleCms Color management library (http://www.littlecms.com)
lcms-1.18a.zip (2009-04-19)

In the following subsections each component is discussed in detail. The order of the subsections seems random, but I applied the approach to describe the precompiled packages first, followed by the big packages, where some of the small packages depend on.

The decompress step of each component contains seemingly inconsistent namings of destination directories, because in some components a subdirectory is specified as destination directory and in some steps only the base directory. This is due to the fact that some package archives contain a base directory and some not. To check the right locations each result section of every component's description contains a summary of the expected files.

The SDK is currently outdated. The following changes are necessary to build Hugin:

Directory Description (Website)
Download package
freeglut_2.6.0 Freeglut (http://freeglut.sourceforge.net/index.php)
freeglut-2.6.0.tar.gz
make_3.81 GNU make 3.81 (http://www.gnu.org/software/make/)
make-3.81.tar.gz
This package replaces UnxUtils.
Templatized C++ Command Line Parser 1.2.0 tclap (http://tclap.sourceforge.net/)
tclap-1.2.0.tar.gz


Diff Files

In order to make compilation simple, a series of patch files are included below that contain all the necessary changes, not only to compile the SDK, but to optionally compile an x64 version of the SDK. When directed, you will need to apply the patch file specified. If you are compiling for x64, there may be additional patches you need to apply.

The download link for the patches is https://bugs.launchpad.net/hugin/+bug/679695/+attachment/1741338/+files/hugin_patches.zip

In order to apply a patch, you will first have needed to follow directions for the UnxUtils step. You cannot apply any patches before that step. To apply a patch, follow these directions:

  1. Start a Command Prompt by choosing Start -> Run and typing in "cmd.exe"
  2. On the Command Prompt, change directory to <SDKHOME>
    Example
    C:\Program Files\Microsoft\Windows SDK\v6.1>d:
    
    D:>cd \usr\src\SDK
    
    D:\usr\src\SDK>
    
  3. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key, substituting <SDKHOME> where appropriate:
    set PATH=%PATH%;<SDKHOME>\UnxUtils\usr\local\wbin
    
  4. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key, substituting <PATCHFILE> with the name of the patch file to apply:
    patch -p 0 -i <PATCHFILE>
    

    NOTE: On Vista and later systems, the filename "patch.exe" is a protected file name which will always result in a UAC prompt if the file does not include a manifest (which UnxUtils version does not). This can be worked around by copying the file <SDKHOME>\UnxUtils\usr\local\wbin\patch.exe to another file not containing the name, such as <SDKHOME>\UnxUtils\usr\local\wbin\apply_diff.exe. Then substitute the command 'patch' in the above command with 'apply_diff'

Result

If everything worked, you should see a list of filenames that were patched. Example

D:\usr\src\SDK>patch -p 0 -i libiconv-1.9.1.diff
patching file 'libiconv-1.9.1/srclib/error.c'

D:\usr\src\SDK>

If there was an error, you may wish to consult the Hugin SDK (MSVC 2008) Patches page for instructions on what changes were contained in the patch.

UnxUtils

  1. Create the directory <SDKHOME>\UnxUtils
  2. Decompress the file UnxUtils.zip to created directory <SDKHOME>\UnxUtils

Result

The applications reside in <SDKHOME>\UnxUtils\bin and <SDKHOME>\UnxUtils\usr\local\wbin

ExifTool

  1. Create the directory <SDKHOME>\exiftool
  2. Decompress the file exiftool-7.74.zip to <SDKHOME>\exiftool
  3. Rename the file exiftool(-k).exe to exiftool.exe

Result

The application resides in <SDKHOME>\exiftool

GetText

32-Bit Directions 64-Bit Directions
  1. Create the directory <SDKHOME>\gettext
  2. Decompress the following files to created directory <SDKHOME>\gettext
    • gettext-runtime-0.13.1.bin.woe32.zip
    • gettext-tools-0.13.1.bin.woe32.zip
    • libiconv-1.9.1.bin.woe32.zip
  1. Create the directory <SDKHOME>\gettext
  2. Decompress the following files into the directory <SDKHOME>
    • gettext-0.13.1.tar.gz
    • libiconv-1.9.1.tar.gz

    After decompress, there should be two new folders in <SDKHOME>: <SDKHOME>\gettext-0.13.1 and <SDKHOME>\libiconv-1.9.1

  3. Apply the libiconv-1.9.1.diff patch
  4. Apply the gettext-0.13.1.diff patch
  5. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v6.1 -> CMD Shell
  6. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
    setenv /Release /x64 /xp
    

    It should now refresh and say

    Setting SDK environment relative to <path where you installed the SDK>
    Targeting Windows XP x64 RELEASE
    
  7. On the command prompt, change directory to <SDKHOME>\libiconv-1.9.1
    Example
    C:\Program Files\Microsoft\Windows SDK\v6.1>d:
    
    D:>cd \usr\src\SDK\libiconv-1.9.1
    
    D:\usr\src\SDK\libiconv-1.9.1>
    
  8. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key, substituting <SDKHOME> where appropriate:
    nmake -f Makefile.msvc NO_NLS=1 MFLAGS=-MT
    nmake -f Makefile.msvc NO_NLS=1 MFLAGS=-MT install PREFIX=<SDKHOME>\gettext
    cd ..\gettext-0.13.1
    nmake -f Makefile.msvc MFLAGS=-MT PREFIX=<SDKHOME>\gettext
    nmake -f Makefile.msvc MFLAGS=-MT install PREFIX=<SDKHOME>\gettext
    cd ..\libiconv-1.9.2-src
    nmake -f Makefile.msvc NO_NLS=1 MFLAGS=-MT distclean
    nmake -f Makefile.msvc MFLAGS=-MT PREFIX=<SDKHOME>\gettext
    nmake -f Makefile.msvc MFLAGS=-MT install PREFIX=<SDKHOME>\gettext
    
  9. Close the Windows SDK command prompt window

Result

The applications reside in <SDKHOME>\gettext\bin

The include files reside in <SDKHOME>\gettext\include

The libraries reside in <SDKHOME>\gettext\lib

STLport (64-bit Only)

  1. Decompress the file STLport-5.2.1.tar.gz to directory <SDKHOME>
  2. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v6.1 -> CMD Shell
  3. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
    setenv /Release /x64 /xp
    

    It should now refresh and say

    Setting SDK environment relative to <path where you installed the SDK>
    Targeting Windows XP x64 RELEASE
    
  4. On the command prompt, change directory to <SDKHOME>\STLport-5.2.1
    Example
    C:\Program Files\Microsoft\Windows SDK\v6.1>d:
    
    D:>cd \usr\src\SDK\STLport-5.2.1
    
    D:\usr\src\SDK\STLport-5.2.1>
    
  5. On the command prompt, enter the following commands without any line breaks and press the Return/Enter key:
    configure msvc9 --with-static-rtl
    cd build/lib
    nmake clean install
  6. Close the Windows SDK command prompt window

Result

The libraries reside in <SDKHOME>\STLport-5.2.1\lib

lcms-1.18 (64-bit Only)

  1. Decompress the file lcms-1.18a.tar.gz to directory <SDKHOME>
  2. Apply the lcms-1.18.diff patch
  3. Open the file <SDKHOME>\lcms-1.18\Projects\VC2008\lcms.sln
  4. Select "Release" in the Solution Configuration pull-down menu. Select "x64" in the Solution Platform pull-down menu
  5. Select project lcms in Solution Explorer, and then choose Build > Project Only > Build Only lcms
  6. Close Visual Studio C++ 2008 Express Edition

Result

The library resides in <SDKHOME>\lcms-1.18\Lib\MS

Note
During build process temporary object files are stored in following directories
  • <SDKHOME>\lcms-1.18\Projects\VC2008\LibDebug
  • <SDKHOME>\lcms-1.18\Projects\VC2008\LibRelease

Both directories may be deleted to save disk space.

libxmi-1.2.1 (64-bit Only)

  1. Open the file libxmi-1.2-1.src.zip in 7-Zip
  2. Open the "src" folder by double-clicking
  3. Open the "libxmi" folder by double-clicking
  4. Open the "1.2" folder by double-clicking
  5. Extract "libxmi-1.2" to the directory <SDKHOME>
  6. Apply the libxmi-1.2.diff patch

Result

The libxmi-1.2 sources now reside in <SDKHOME>\libxmi-1.2

wxWidgets

  1. Decompress the file wxMSW-2.8.10.zip to directory <SDKHOME>
  2. Rename the directory <SDKHOME>\wxMSW-2.8.10 to <SDKHOME>\wxWidgets-2.8.10
  3. Apply the wxWidgets-2.8.10.diff patch Hugin SDK (MSVC 2008) Patches#wxWidgets
  4. 32-Bit Directions 64-Bit Directions
    To open a Visual Studio command prompt choose Start > Programs > Microsoft Visual C++ 2008 Express Edition > Visual Studio Tools > Visual Studio 2008 Command Prompt
    1. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v6.1 -> CMD Shell
    2. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
      setenv /Release /x64 /xp
      

      It should now refresh and say

      Setting SDK environment relative to <path where you installed the SDK>
      Targeting Windows XP x64 RELEASE
      
  5. On command prompt change directory to <SDKHOME>\wxWidgets-2.8.10\build\msw
    Example
    C:\Program Files\Microsoft Visual Studio 9.0\VC>d:
    
    D:\>cd \usr\src\SDK\wxWidgets-2.8.10\build\msw
    
    D:\usr\src\SDK\wxWidgets-2.8.10\build\msw>
    
  6. Enter each of the following two commands without any line break and press the Return key
    32-Bit Directions 64-Bit Directions
    nmake -f makefile.vc BUILD=debug UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    nmake -f makefile.vc BUILD=release UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    
    nmake -f makefile.vc BUILD=debug TARGET_CPU=AMD64 UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    nmake -f makefile.vc BUILD=release TARGET_CPU=AMD64 UNICODE=1 SHARED=0 USE_OPENGL=1 RUNTIME_LIBS=static
    
  7. Close the Windows SDK command prompt window
  8. (64-bit Only)Rename the folder <SDKHOME>wxWidgets-2.8.10\lib\vc_amd64_lib to <SDKHOME>wxWidgets-2.8.10\lib\vc_lib

Result

The include files reside in <SDKHOME>\wxWidgets-2.8.10\include and its subdirectories

Additional Hugin depends on following files

  • <SDKHOME>\wxWidgets-2.8.10\src\jpg\*.h
  • <SDKHOME>\wxWidgets-2.8.10\src\jpg\jconfig.vc
  • <SDKHOME>\wxWidgets-2.8.10\src\png\*.h
  • <SDKHOME>\wxWidgets-2.8.10\src\tiff\*.h
  • <SDKHOME>\wxWidgets-2.8.10\src\zlib\*.h

The libraries reside in <SDKHOME>\wxWidgets-2.8.10\lib\vc_lib

Note
During build process temporary object files are stored in following directories
32-Bit 64-Bit
  • <SDKHOME>\wxWidgets-2.8.10\build\msw\vc_mswu
  • <SDKHOME>\wxWidgets-2.8.10\build\msw\vc_mswud
  • <SDKHOME>\wxWidgets-2.8.10\build\msw\vc_mswu_amd64
  • <SDKHOME>\wxWidgets-2.8.10\build\msw\vc_mswud_amd64

Both directories may be deleted to save disk space.

Boost

  1. Decompress the file boost_1_39_0.7z to directory <SDKHOME>
  2. Decompress the file boost-jam-3.1.17-1-ntx86.zip to an arbitrary directory and copy the application bjam.exe to <SDKHOME>\boost_1_39_0
  3. To open a Windows command prompt choose Start > Run, then enter cmd.exe and click OK.
  4. On command prompt change directory to <SDKHOME>\boost_1_39_0
    Example
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.
    
    C:\Dokuments and Settings\Guido>d:
    
    D:\>cd \usr\src\SDK\boost_1_39_0
    
    D:\usr\src\SDK\boost_1_39_0>
    
  5. Enter the following command without line breaks and press Return key
    32-Bit Directions 64-Bit Directions
    bjam --with-date_time --with-thread toolset=msvc variant=debug variant=release link=static threading=multi runtime-link=static stage
    

    After bjam.exe finished a statement like the following should be printed in the command prompt window

    ...updated 56 targets...
    
    d:\usr\src\SDK\boost_1_39_0>
    

    Since September 2010 Hugin requieres also the boost libraries regex, filesystem, iostream and system, since November 2010 also the boost library signals. If you want to compile this version you need to compile Boost lib with

    bjam --with-date_time --with-thread --with-regex --with-filesystem --with-iostreams --with-system --with-signals toolset=msvc variant=debug variant=release link=static threading=multi runtime-link=static stage
    
    bjam --with-date_time --with-thread toolset=msvc variant=debug variant=release link=static threading=multi runtime-link=static address-model=64 stage
    

    After bjam.exe finished a statement like the following should be printed in the command prompt window

    ...updated 26 targets...
    
  6. Close the Windows command prompt window

Result

The include files reside in <SDKHOME>\boost_1_39_0 and its subdirectory boost

The libraries reside in <SDKHOME>\boost_1_39_0\stage\lib

Notes
  • During build process temporary files are generated in <SDKHOME>\boost_1_39_0\bin.v2. This directory may be deleted to save disk space.
  • Hugin needs only the two Boost libraries date_time and thread, thus only these two libraries have to be built.
    If you want to build all Boost libraries enter following command on the Windows command prompt instead of the command described above and press Return key.
    bjam -–build-type=complete toolset=msvc stage
    

    There are about 7GB disc space needed during build of all libraries (3.5GB for libraries and the same amount for the temporary files).

  • The Boost include files are typically included by a statement like
    #include "boost/whatever.hpp"
    Therefore the base directory of the Boost include files is <SDKHOME>\boost_1_39_0
  • Only the following libraries are needed to build a release version of Hugin:
    • libboost_date_time-vc90-mt-s-1_39.lib
    • libboost_thread-vc90-mt-s-1_39.lib

    The files with "gd" in the filename, e.g. libboost_thread-vc90-mt-sgd-1_39.lib, are the debug libraries. The library files without "-1_39" suffix are automatically generated copies of the libraries with version suffix. They are used by CMake to detect the library directory.

OpenEXR

OpenEXR depends on following SDK component:

  • wxWidgets

Prepare this component before OpenEXR.

  1. Create the directory <SDKHOME>\OpenEXR
  2. Decompress the file ilmbase-1.0.1.tar.gz to created directory <SDKHOME>\OpenEXR
  3. Decompress the file openexr-1.6.1.tar.gz to the same directory <SDKHOME>\OpenEXR
    After decompress there should only exist the two directories ilmbase-1.0.1 and openexr-1.6.1 in <SDKHOME>\OpenEXR
  4. Apply the OpenEXR.diff patch Hugin SDK (MSVC 2008) Patches#OpenEXR
  5. Open solution file <SDKHOME>\OpenEXR\ilmbase-1.0.1\vc\vc8\IlmBase\IlmBase.sln
  6. Select Debug in Solutions Configuration pull-down menu, and then choose Build > Build Solution
  7. Select Release in Solutions Configuration pull-down menu, and then choose Build > Build Solution
  8. Open solution file <SDKHOME>\OpenEXR\openexr-1.6.1\vc\vc8\OpenEXR\OpenEXR.sln
  9. Choose Build > Batch Build
  10. Select Build for Project IlmImf with Solution Config
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  11. Click Build
  12. Close Visual C++ 2008 Express Edition

Result

The include files reside in <SDKHOME>\Deploy\include

The libraries reside in <SDKHOME>\Deploy\lib\Debug and <SDKHOME>\Deploy\lib\Release

Enblend and Enfuse

32-Bit Directions 64-Bit Directions
  1. Decompress the file enblend-enfuse-3.2.zip to directory <SDKHOME>
Enblend & Enfuse depend on the following SDK components:
  • wxWidgets
  • OpenEXR
  • lcms
  • STLport
  • boost
  • libxmi

Prepare these components before Enblend & Enfuse.

  1. Decompress the file enblend-enfuse-3.2.tar.gz to directory <SDKHOME>
    After decompression, you should now have a folder <SDKHOME>\enblend-enfuse-3.2
  2. Apply the enblend-enfuse-3.2.diff patch Hugin SDK (MSVC 2008) Patches#Enblend/Enfuse/libxmi
  3. Open the file <SDKHOME>\enblend-enfuse-3.2\enblend_msvc2008.sln
  4. Select Release in Solutions Configuration pull-down menu, choose x64 in the Solutions Platform pull-down menu, and then choose Build > Build Solution
  5. Close Visual C++ 2008 Express Edition

Result

The applications reside in <SDKHOME>\enblend-enfuse-3.2

Expat

  1. Decompress the file expat-2.0.1.tar.gz to directory <SDKHOME>
  2. Apply the expat-2.0.1.diff patch Hugin SDK (MSVC 2008) Patches#expat
  3. Open the file <SDKHOME>\expat-2.0.1\Source\expat.sln
  4. Choose Build > Batch Build
  5. Select Build for Project expat_static with
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  6. Click Build
  7. Close Visual C++ 2008 Express Edition

Result

The include files reside in <SDKHOME>\expat-2.0.1\lib

The libraries reside in <SDKHOME>\expat-2.0.1\win32\bin\Debug and <SDKHOME>\expat-2.0.1\win32\bin\Release

Exiv2

Exiv2 depends on following SDK components:

  • wxWidgets
  • GetText
  • Expat

Prepare these components before Exiv2.

  1. Decompress the file exiv2-0.18.1.tar.gz to directory <SDKHOME>
  2. Apply the exiv2-0.18.1.diff patch Hugin SDK (MSVC 2008) Patches#exiv2
  3. (64-bit Only)Apply the exiv2-0.18.1.x64.diff patch
  4. Open solution file <SDKHOME>\exiv2-0.18.1\msvc\exiv2.sln
  5. In the Solution Explorer, select "exiv2lib"
  6. Select Debug in Solutions Configuration pull-down menu and your platform in the Solution Platform pull-down menu, and then choose Build > Build exiv2lib
  7. Select Release in Solutions Configuration pull-down menu and your platform in the Solution Platform pull-down menu, and then choose Build > Build exiv2lib
  8. Close Visual C++ 2008 Express Edition
  9. Create the directory <SDKHOME>\exiv2-0.18.1\msvc\lib
  10. Copy the following files to this directory and rename them as specified in Destination column.
    Source Destination
    <SDKHOME>\exiv2-0.18.1\msvc\bin\Debug\exiv2.lib <SDKHOME>\exiv2-0.18.1\msvc\lib\exiv2d.lib
    <SDKHOME>\exiv2-0.18.1\msvc\bin\Release\exiv2.lib <SDKHOME>\exiv2-0.18.1\msvc\lib\exiv2.lib
    <SDKHOME>\expat-2.0.1\win32\bin\Debug\libexpatMT.lib <SDKHOME>\exiv2-0.18.1\msvc\lib\libexpatd.lib
    <SDKHOME>\expat-2.0.1\win32\bin\Release\libexpatMT.lib <SDKHOME>\exiv2-0.18.1\msvc\lib\libexpat.lib

Comment

When using exiv2 0.19 (which works better with bigger files), copy and rename also the following files:

Source Destination
<SDKHOME>\exiv2-0.19\msvc\xmpsdk\Debug\xmpsdk.lib <SDKHOME>\exiv2-0.19\msvc\lib\xmpsdkd.lib
<SDKHOME>\exiv2-0.19\msvc\xmpsdk\Release\xmpsdk.lib <SDKHOME>\exiv2-0.19\msvc\lib\xmpsdk.lib

Result

The include files reside in <SDKHOME>\exiv2-0.18.1\msvc\include

The libraries reside in <SDKHOME>\exiv2-0.18.1\msvc\lib

GLEW

  1. Decompress the file glew-1.5.1-src.zip to directory <SDKHOME>
  2. Apply the glew.diff patch Hugin SDK (MSVC 2008) Patches#glew
  3. Open the file <SDKHOME>\glew\build\vc6\glew.sln
  4. Choose Build > Batch Build
  5. Select Build for Project glew_static with Solution Config
    32-Bit 64-Bit
    Solution Config: "Debug" with Platform: "Win32"

    Solution Config: "Release" with Platform: "Win32"

    Solution Config: "Debug" with Platform: "x64"

    Solution Config: "Release" with Platform: "x64"

  6. Click Build
  7. Close Visual C++ 2008 Express Edition

Result

The include files reside in <SDKHOME>\glew\include

The libraries reside in <SDKHOME>\glew\lib

Note
The GLEW include files are typically included by a statement like
#include "GL/glew.h"
Therefore the base directory of the GLEW include files is <SDKHOME>\glew\include

Panorama Tools

Panorama Tools depends on following SDK component:

  • wxWidgets

Prepare this component before Panoroma Tools.

  1. Set two windows environment variables:
    • Set variable WXWIDGETS_HOME to wxWidgets base folder <SDKHOME>\wxWidgets-2.8.10
    • Set variable JDK_HOME to Java SE Development Kit's destination directory name. This directory name was shown during the setup, e.g. C:\Program Files\Java\jdk1.6.0_13

    To take effect on changes of environment variables you may have to logout and login.

  2. Create the directory <SDKHOME>\libpano\pano13
  3. In explorer right-click on created directory <SDKHOME>\libpano\pano13
  4. , and then choose SVN Checkout from the shortcut menu. The Checkout dialog appears.
  5. In "URL of repository" field enter following address:
    https://panotools.svn.sourceforge.net/svnroot/panotools/trunk/libpano
    
  6. Click OK
  7. After checkout has finished click OK
  8. Apply the libpano.diff patch Hugin SDK (MSVC 2008) Patches#Panorama Tools
  9. Open solution file <SDKHOME>\libpano\pano13\libpano.sln
  10. Select your platform in the Solution Platform pull-down menu
  11. Select "Debug LIB CMD" in Solution Configuration pull-down menu
  12. Select project pano13 in Solution Explorer, and then choose Build > Project Only > Build Only pano13
  13. Select "Release LIB CMD" in Solution Configuration pull-down menu, and then choose Build > Build Solution
  14. Close Visual C++ 2008 Express Edition

Result

The applications reside in <SDKHOME>\libpano\pano13\tools\Release

The include files reside in <SDKHOME>\libpano\pano13

The libraries reside in "<SDKHOME>\libpano\pano13\Debug LIB CMD" and "<SDKHOME>\libpano\pano13\Release LIB CMD"

Note
The applications have to be built in release version only. Therefore only pano13 library has to be built in Debug configuration.

libxml2

  1. Decompress the file libxml2-sources-2.7.3.tar.gz to directory <SDKHOME>
  2. 32-Bit Directions 64-Bit Directions
    1. To open a Visual Studio command prompt choose Start > Programs > Microsoft Visual C++ 2008 Express Edition > Visual Studio Tools > Visual Studio 2008 Command Prompt
    1. Open a Windows SDK prompt by choosing Start -> Programs -> Microsoft Windows SDK v6.1 -> CMD Shell
    2. On the command prompt, enter the following command without any line breaks and press the Return/Enter key:
      setenv /Release /x64 /xp
      

      It should now refresh and say

      Setting SDK environment relative to <path where you installed the SDK>
      Targeting Windows XP x64 RELEASE
      
  3. On command prompt change directory to <SDKHOME>\libxml2-2.7.3\win32
    Example
    Setting environment for using Microsoft Visual Studio 2008 x86 tools.
    
    C:\Program Files\Microsoft Visual Studio 9.0\VC>d:
    
    D:\>cd \usr\src\SDK\libxml2-2.7.3\win32 
    
    D:\usr\src\SDK\libxml2-2.7.3\win32>
    
  4. Enter each of the following two commands without any line break and press the Return key.
    cscript configure.js ftp=no http=no iconv=no cruntime=/MT
    nmake -f makefile.msvc libxmla
    

Result

The include files reside in <SDKHOME>\libxml2-2.7.3\include

The libraries reside in <SDKHOME>\libxml2-2.7.3\win32\bin.msvc

Notes
  • During build process temporary object files are generated in directory <SDKHOME>\libxml2-2.7.3\win32\int.a.msvc. This directories may be deleted to save disc space.
  • Hugin does not depend on libxml2 library, but autopano-sift-C. Therefore it is included in this SDK.

autopano-sift-C

Autopano-SIFT-C depends on following SDK components:

  • libxml2
  • Panorama Tool's pano13 library
  • wxWidgets

Prepare these components before Autopano-SIFT-C.

  1. Create the directory <SDKHOME>\autopano-sift-C-trunk
  2. In explorer right-click on created directory <SDKHOME>\autopano-sift-C-trunk, and then choose SVN Checkout from the shortcut menu. The Checkout dialog appears.
  3. In "URL of repository" field enter following address:
    https://hugin.svn.sourceforge.net/svnroot/hugin/autopano-sift-C/trunk
    
  4. Click OK
  5. After checkout has finished click OK
  6. Start CMake (cmake-gui). The CMake dialog appears.
  7. In "Where is the source code" field enter
    <SDKHOME>\autopano-sift-C-trunk
    
    Alternatively click Browse Source to point to this directory
  8. In "Where to build the binaries" field enter
    <SDKHOME>\autopano-sift-C
    
  9. Click Configure
    If a dialog appears, which asks to create the build directoy, click Yes.
    A dialog appears, where you can specify the generator for the project.
  10. 32-Bit Directions 64-Bit Directions
    Select "Visual Studio 9 2008" and select option "Use default native compilers" Select "Visual Studio 9 2008 Win64" and select option "Use default native compilers"
  11. Click Finish
    In the Name and Value list the entries are shown with red background.
  12. Click Configure
  13. Click Generate
  14. Close CMake
  15. Open solution file <SDKHOME>\autopano-sift-C\autopano-sift-C.sln
  16. Select Release in Solution Configuration pull-down menu, and then choose Build > Build Solution
  17. Select project INSTALL in Solution Explorer, and then choose Build > Project Only > Build Only INSTALL
  18. Close Visual C++ 2008 Express Edition
  19. Copy the directories bin and shared from <SDKHOME>\autopano-sift-C\INSTALL\FILES to <SDKHOME>\autopano-sift-C

Result

The applications reside in <SDKHOME>\autopano-sift-C\bin

The manual pages reside in <SDKHOME>\autopano-sift-C\shared

Note
To save disk space you may delete all files and directories in <SDKHOME>\autopano-sift-C, except the subdirectories bin and shared.

Freeglut

  1. Decompress the file freeglut-2.6.0.tar.gz to directory <SDKHOME>
  2. Open the file <SDKHOME>\freeglut-2.6.0\VisualStudio2008Static\freeglut.sln
  3. Select "Debug" in the Solution Configuration pull-down menu.
  4. Select project freeglut in Solution Explorer, and then choose Build > Project Only > Build Only freeglut
  5. Select "Release" in the Solution Configuration pull-down menu.
  6. Select project freeglut in Solution Explorer, and then choose Build > Project Only > Build Only freeglut
  7. Close Visual Studio C++ 2008 Express Edition

Result

The library resides in <SDKHOME>\freeglut-2.6.0\VisualStudio2008Static\Debug and <SDKHOME>\freeglut-2.6.0\VisualStudio2008Static\Release

GNU Make

  1. Decompress the file make-3.81.tar.gz to directory <SDKHOME>
  2. Open the file <SDKHOME>\make-3.81\make_msvc_net2003.sln (Confirm convertion.)
  3. Select "Release" in the Solution Configuration pull-down menu.
  4. Select project make_msvc.net2003 Solution Explorer, and then choose Build > Project
  5. Close Visual Studio C++ 2008 Express Edition
  6. Rename the file <SDKHOME>\make-3.81\Release\make_msvc.net2003.exe to <SDKHOME>\make-3.81\Release\make.exe

Result

The executable make.exe resides in <SDKHOME>\make-3.81\Release\

(All other files in this directory can be deleted to save space.)

Templatized C++ Command Line Parser Library (tclap)

  1. Decompress the file tclap-1.2.0.tar.gz to directory <SDKHOME>\tclap-1.2.0

Result

The include files reside in <SDKHOME>\tclap-1.2.0\include\tclap


Ryan Sleevi 17:00, 9 May 2009 (UTC)