Hugin Compiling OpenSuse

From PanoTools.org Wiki
(Difference between revisions)
Jump to: navigation, search
m (categorized)
Line 52: Line 52:
 
* The only non-standard thing is libpano13, (2.9.12 was used)
 
* The only non-standard thing is libpano13, (2.9.12 was used)
 
* All other dependencies have been resolved using the standard (smart) repositories for OpenSuSE (wxGTK is 2.6.3.3).
 
* All other dependencies have been resolved using the standard (smart) repositories for OpenSuSE (wxGTK is 2.6.3.3).
 +
 +
[[Category:Software:Platform:Linux]]
 +
[[Category:Software:Hugin]]

Revision as of 01:34, 18 November 2007

  • Confirmed working on OpenSuSE 10.3 and x86_64 architecture.
  • Enblend 3.0 comes standard with the distribution
  • libpano and hugin in the distribution are outdated
  • everything but libpano and hugin can be found in the repositories
  • to build libpano and hugin, follow the instructions below
  1. Dependencies needed for OpenSuSE 10.3
    gettext
    libjpeg-devel
    boost-devel
    boost
    wxGTK-devel
    wxGTK
    OpenEXR-devel
    openEXR
  2. compile and install pano13
    mkdir -p /usr/src/panotools/trunk
    cd /usr/src/panotools/trunk
    svn co https://panotools.svn.sourceforge.net/svnroot/panotools/trunk/libpano libpano13
    cd libpano13
    sh ./bootstrap
    make
    sudo make install
  3. Install cmake
  4. create the svn-source-directory /usr/src/hugin
    mkdir /usr/src/hugin
    cd /usr/src/hugin
    svn co https://hugin.svn.sourceforge.net/svnroot/hugin/hugin/trunk hugin
  5. create build-directory
    mkdir /usr/src/hugin/BuildHugin
    
  6. configure
    cd /usr/src/hugin/BuildHugin
    
    ccmake /usr/src/hugin/hugin
    cmake /usr/src/hugin/hugin
  7. make and install
    make
    
    sudo make install


Success Report: On OpenSuSE 10.2 ist's really straightforward.

  • clean SVN chechout (version as of 20070204)
  • followed the instructions in INSTALL_cmake.
  • The only non-standard thing is libpano13, (2.9.12 was used)
  • All other dependencies have been resolved using the standard (smart) repositories for OpenSuSE (wxGTK is 2.6.3.3).
Personal tools
Namespaces

Variants
Actions
Navigation
tools
Tools