How to use PTEditor

From PanoTools.org Wiki
(Difference between revisions)
Jump to: navigation, search
m (Additional functions:: added Pano2QTVR)
m (categorized)
 
(6 intermediate revisions by 3 users not shown)
Line 19: Line 19:
 
6. When the file is opened, navigate with mouse or keyboard arrows to the region who needs retouching. (The navigation is similar to [[PTViewer]])
 
6. When the file is opened, navigate with mouse or keyboard arrows to the region who needs retouching. (The navigation is similar to [[PTViewer]])
  
Ctrl + leftmouseclick=> zoom in
+
Shift + leftmouseclick=> zoom in
  
Shift + leftmouseclick => zoom out
+
Ctrl + leftmouseclick => zoom out
  
  
Line 96: Line 96:
 
<br>
 
<br>
 
--[[User:Pitdavos|Peter Nyfeler]]  (Pitdavos)
 
--[[User:Pitdavos|Peter Nyfeler]]  (Pitdavos)
 +
 +
[[Category:Tutorial:Basic need]]

Latest revision as of 19:07, 21 March 2007

1. The whole thing is easier than it looks like at first!

2. PTEditor (pteditor.jar) is found in the Panorama Tools (I use version 2.6b1)

3. Make a shortcut to the desktop and be aware of spaces in the root.

4. Doubleclick the icon and it should look like this:

Pte tutorial 001.jpg


5. Under Menu File click to open panorama and choose the desired equirectangular panorama (possible formats : TIFF, JPEG, PNG, BMP)

Pte tutorial 002.jpg


6. When the file is opened, navigate with mouse or keyboard arrows to the region who needs retouching. (The navigation is similar to PTViewer)

Shift + leftmouseclick=> zoom in

Ctrl + leftmouseclick => zoom out


7.When you have zoomed in enough (really important, because this way the extracted file isn't that big in size), choose Extract Partial View under menu Edit.

Pte tutorial 003.jpg


8. A Dialog opens to let you save this partial view. Default setting is Image.tif (I always keep this name as is and save the newer views over it, only to get rid of to much trash on my computer)

Pte tutorial 004.jpg


9. When saved, open this file in a image editor software like Photoshop, gimp and so on and retouch it.

The final file should be flattened to background after retouching. Save and close the partial panorama file.


10. The retouched Image.tif can now be re-inserted. Go back to PTEditor window and choose Insert saved View under menu Edit.The retouched part (Image.tif) will be inserted in a few seconds.

Pte tutorial 005.jpg


11. Don't forget to save the modified panorama:

Pte tutorial 006.jpg


12. Repeat the steps number 7 to 10 as much as you like until the whole panorama is retouched.

I think this is one of the easiest ways to retouch a panorama, also in zenith and nadir regions. No remapping is needed that causes loss of quality (8 bit workflow).



[edit] Additional functions:

A. By pressing the key i, you get used version on the bottom border:

Pte tutorial 007.jpg


B. By pressing the key v; you get the actual position where you navigated to:

Pte tutorial 008.jpg


This is really useful, when you have to add a special starting position in PanoCube or Pano2QTVR.

Attention: Sometimes you have to hit the key twice to show this dialog on the bottom border.

The used version of pano12 in this workflow is '2.7.0.6'

[edit] How to allocate enough RAM for PTEditor

With big sized panoramas PTEditor tends to do nothing because of too little allocated RAM. To avoid this just read the following tutorial:

How to allocate enough RAM for PTEditor


--Peter Nyfeler (Pitdavos)

Personal tools
Namespaces

Variants
Actions
Navigation
tools
Tools