How to use PTEditor

From PanoTools.org Wiki
(Difference between revisions)
Jump to: navigation, search
m
Line 1: Line 1:
 
  
 
1. The whole thing is easier as it looks like first!
 
1. The whole thing is easier as it looks like first!
Line 5: Line 4:
 
2. PTEditor (pteditor.jar) is to find in the panorama tools (I use version 2.6b1)
 
2. PTEditor (pteditor.jar) is to find in the panorama tools (I use version 2.6b1)
  
3. Make a shortcut to the desktop an be aware of spaces in the root.
+
3. Make a shortcut to the desktop and be aware of spaces in the root.
  
 
4. Doubleclick the icon and it should look like this:
 
4. Doubleclick the icon and it should look like this:

Revision as of 11:44, 8 February 2005

1. The whole thing is easier as it looks like first!

2. PTEditor (pteditor.jar) is to find in the panorama tools (I use version 2.6b1)

3. Make a shortcut to the desktop and be aware of spaces in the root.

4. Doubleclick the icon and it should look like this:

Pte tutorial 001.jpg


5. Under Menue File click to open panorama and choose the desired equirectangular panorama (possible formats : tiff, jpg, png, bmp)

Pte tutorial 002.jpg


6. When the file is opened, navigate with mouse or keyboard arrows to the region who needs retouching. (The navigation is similar to PTViewer)

Ctrl + leftmouseclick=> zoom in

Shift + leftmouseclick => zoom out


7.When you have zoomed in enough (really important, because this way the extractet file isn't that big in size), choose Extract Partial View under menue Edit.

Pte tutorial 003.jpg


8. A Dialog opens and let you save tis partial view. Default setting is Image.tif (I always let this name as is and save the newer views over it, only to get rid of to much trash on my computer)

Pte tutorial 004.jpg


9. When save, open this file in a image editor software like photoshop, gimp and so on and retouch it.

The final file should be flattened to background after retouching. Save and close the partial panorama file.


10. The retouched Image.tif can now be re-inserted. Go back to PTEditor window and choose Insert saved View under menue Edit.The retouched part (Image.tif) will be inserted in a few seconds.

Pte tutorial 005.jpg


11. Don't forget to save the modified panorama:

Pte tutorial 006.jpg


12. Repeat the steps number 7 to 10 as much as you like and the whole panoroama is retouched.

I think this is one of the easiest ways to retouch a panorama, also in zenith and nadir regions. No remapping is needed that causes quality (8 bit workflow).



Additional functions:

A. By pressing the key i, you get used version on the bottom border:

Pte tutorial 007.jpg


B. By pressing the key v; you get the actual position where you navigated to:

Pte tutorial 008.jpg


This is really usefull, when you have to add e special starting position in PanoCube.

Attention: Sometimes you have to hit the key twice for showing this dialog on the bottom border.

The used version of pano12.dll in this workflow is '2.7.0.6'



How to allocate enough RAM for PTEditor

With big sized panoramas PTEditor tends to do nothing because of too few allocatet RAM. To avoid this just read the following tutorial:

How to allocate enough RAM for PTEditor

Personal tools
Namespaces

Variants
Actions
Navigation
tools
Tools